summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/dclib')
-rw-r--r--net-p2p/dclib/Manifest1
-rw-r--r--net-p2p/dclib/dclib-0.3.23.ebuild39
-rw-r--r--net-p2p/dclib/files/dclib-0.3.23-asneeded.patch16
-rw-r--r--net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch52
-rw-r--r--net-p2p/dclib/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/net-p2p/dclib/Manifest b/net-p2p/dclib/Manifest
new file mode 100644
index 000000000000..cf90b79247f3
--- /dev/null
+++ b/net-p2p/dclib/Manifest
@@ -0,0 +1 @@
+DIST dclib-0.3.23.tar.bz2 517251 SHA256 757b67cb1158a93fd826ef358ec094f59ba9dca0dde94a1d7325833f222e4dd0
diff --git a/net-p2p/dclib/dclib-0.3.23.ebuild b/net-p2p/dclib/dclib-0.3.23.ebuild
new file mode 100644
index 000000000000..3945a73501a5
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.3.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="DirectConnect client library"
+HOMEPAGE="http://sourceforge.net/projects/wxdcgui"
+SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="socks5 ssl"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable socks5 socks) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
new file mode 100644
index 000000000000..d3634c424c2e
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
@@ -0,0 +1,16 @@
+Changing order allows ACX_PHTREAD to find -lthread
+before trying to use -pthread
+
+http://bugs.gentoo.org/show_bug.cgi?id=282426
+
+--- m4/acx_pthread.m4
++++ m4/acx_pthread.m4
+@@ -123,7 +123,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none -Kthread -kthread lthread pthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow:
diff --git a/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch b/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch
new file mode 100644
index 000000000000..f8b4a4bc2af2
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch
@@ -0,0 +1,52 @@
+http://bugs.gentoo.org/330291
+
+--- dclib/core/cssl.cpp
++++ dclib/core/cssl.cpp
+@@ -86,7 +86,11 @@
+ /** */
+ SSL_CTX * CSSL::InitClientCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *method;
++ #else
+ SSL_METHOD *method;
++ #endif
+ SSL_CTX *ctx = NULL;
+
+ method = SSLv23_client_method(); /* Create new client-method instance */
+@@ -109,7 +113,11 @@
+ /** */
+ SSL_CTX * CSSL::InitServerCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *method;
++ #else
+ SSL_METHOD *method;
++ #endif
+ SSL_CTX *ctx = NULL;
+
+ method = SSLv23_server_method(); /* Create new client-method instance */
+@@ -130,7 +138,11 @@
+ /** */
+ SSL_CTX * CSSL::NewTLSv1ClientCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD * method = TLSv1_client_method();
++ #else
+ SSL_METHOD * method = TLSv1_client_method();
++ #endif
+ SSL_CTX * ctx = NULL;
+
+ if ( method != NULL )
+@@ -149,7 +161,11 @@
+ /** */
+ SSL_CTX * CSSL::NewTLSv1ServerCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD * method = TLSv1_server_method();
++ #else
+ SSL_METHOD * method = TLSv1_server_method();
++ #endif
+ SSL_CTX * ctx = NULL;
+
+ if ( method != NULL )
diff --git a/net-p2p/dclib/metadata.xml b/net-p2p/dclib/metadata.xml
new file mode 100644
index 000000000000..b6e0d287755a
--- /dev/null
+++ b/net-p2p/dclib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">wxdcgui</remote-id>
+ </upstream>
+</pkgmetadata>