summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/bind')
-rw-r--r--net-dns/bind/bind-9.10.4_p4.ebuild6
-rw-r--r--net-dns/bind/bind-9.11.0_p2.ebuild8
-rw-r--r--net-dns/bind/bind-9.11.0_p3.ebuild8
3 files changed, 16 insertions, 6 deletions
diff --git a/net-dns/bind/bind-9.10.4_p4.ebuild b/net-dns/bind/bind-9.10.4_p4.ebuild
index cb8726ae585a..de54dd9f9a8f 100644
--- a/net-dns/bind/bind-9.10.4_p4.ebuild
+++ b/net-dns/bind/bind-9.10.4_p4.ebuild
@@ -51,7 +51,8 @@ REQUIRED_USE="postgres? ( dlz )
odbc? ( dlz )
ldap? ( dlz )
gost? ( !libressl ssl )
- threads? ( caps )"
+ threads? ( caps )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# sdb-ldap? ( dlz )
DEPEND="
@@ -70,7 +71,8 @@ DEPEND="
gssapi? ( virtual/krb5 )
gost? ( >=dev-libs/openssl-1.0.0:0[-bindist] )
seccomp? ( sys-libs/libseccomp )
- json? ( dev-libs/json-c )"
+ json? ( dev-libs/json-c )
+ python? ( ${PYTHON_DEPS} )"
# sdb-ldap? ( net-nds/openldap )
RDEPEND="${DEPEND}
diff --git a/net-dns/bind/bind-9.11.0_p2.ebuild b/net-dns/bind/bind-9.11.0_p2.ebuild
index 67a0bdd2b8f5..48e5deb8a319 100644
--- a/net-dns/bind/bind-9.11.0_p2.ebuild
+++ b/net-dns/bind/bind-9.11.0_p2.ebuild
@@ -53,7 +53,8 @@ REQUIRED_USE="postgres? ( dlz )
ldap? ( dlz )
gost? ( !libressl ssl )
threads? ( caps )
- dnstap? ( threads )"
+ dnstap? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# sdb-ldap? ( dlz )
DEPEND="
@@ -76,7 +77,10 @@ DEPEND="
lmdb? ( dev-db/lmdb )
zlib? ( sys-libs/zlib )
dnstap? ( dev-libs/fstrm dev-libs/protobuf-c )
- python? ( dev-python/ply[${PYTHON_USEDEP}] )"
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/ply[${PYTHON_USEDEP}]
+ )"
# sdb-ldap? ( net-nds/openldap )
RDEPEND="${DEPEND}
diff --git a/net-dns/bind/bind-9.11.0_p3.ebuild b/net-dns/bind/bind-9.11.0_p3.ebuild
index f5803cd32ef8..01f489573ada 100644
--- a/net-dns/bind/bind-9.11.0_p3.ebuild
+++ b/net-dns/bind/bind-9.11.0_p3.ebuild
@@ -53,7 +53,8 @@ REQUIRED_USE="postgres? ( dlz )
ldap? ( dlz )
gost? ( !libressl ssl )
threads? ( caps )
- dnstap? ( threads )"
+ dnstap? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# sdb-ldap? ( dlz )
DEPEND="
@@ -76,7 +77,10 @@ DEPEND="
lmdb? ( dev-db/lmdb )
zlib? ( sys-libs/zlib )
dnstap? ( dev-libs/fstrm dev-libs/protobuf-c )
- python? ( dev-python/ply[${PYTHON_USEDEP}] )"
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/ply[${PYTHON_USEDEP}]
+ )"
# sdb-ldap? ( net-nds/openldap )
RDEPEND="${DEPEND}