summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snortalog')
-rw-r--r--net-analyzer/snortalog/Manifest1
-rw-r--r--net-analyzer/snortalog/metadata.xml5
-rw-r--r--net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild57
3 files changed, 63 insertions, 0 deletions
diff --git a/net-analyzer/snortalog/Manifest b/net-analyzer/snortalog/Manifest
new file mode 100644
index 000000000000..f2e1c3945ce6
--- /dev/null
+++ b/net-analyzer/snortalog/Manifest
@@ -0,0 +1 @@
+DIST snortalog_v2.4.3.tar 1324032 SHA256 aa8c47dd5c52277bedb3de310717dfe9f49ca19ededbdc81fbf130b1273ca40f SHA512 b4b8558865ae4d1ef932114f2a2fb5af7fb069f1b587955d9d489a31635e890fb0ed36ebcde19322ab0c0cae49734da08602e283bd731c769de527abf7d74d06 WHIRLPOOL e8fc7d17fa148016218b46add071548bb93a24db4dd26af3b069b9f8d55bbafdcd28a4eb2b68f86346f881b7171f5df81bfa235168496052c34776f6b005dfb3
diff --git a/net-analyzer/snortalog/metadata.xml b/net-analyzer/snortalog/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/snortalog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..3c7f51f357ad
--- /dev/null
+++ b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_P="${PN}_v${PV}"
+
+DESCRIPTION="a powerful perl script that summarizes snort logs"
+HOMEPAGE="http://jeremy.chartier.free.fr/snortalog/"
+SRC_URI="${HOMEPAGE}downloads/${PN}/${MY_P}.tar"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="tk"
+
+RDEPEND="
+ dev-lang/perl[ithreads]
+ dev-perl/HTML-HTMLDoc
+ virtual/perl-DB_File
+ virtual/perl-Getopt-Long
+ tk? ( dev-perl/perl-tk dev-perl/GDGraph )
+"
+
+S=${WORKDIR}
+
+src_prepare() {
+ edos2unix $(find conf/ modules/ -type f) ${PN}.* CHANGES
+
+ # fix paths, erroneous can access message
+ sed -i \
+ -e "s:\(modules/\):/usr/lib/snortalog/${PV}/\1:g" \
+ -e 's:\($domains_file = "\)conf/\(domains\)\(".*\):\1/etc/snortalog/\2\3:' \
+ -e 's:\($rules_file = "\)conf/\(rules\)\(".*\):\1/etc/snortalog/\2\3:' \
+ -e 's:\($picts_dir ="\)picts\(".*\):\1/etc/snortalog/picts\2:' \
+ -e 's:\($hw_file = "\)conf/\(hw\)\(".*\):\1/etc/snortalog/\2\3:' \
+ -e 's:\($lang_file ="\)conf/\(lang\)\(".*\):\1/etc/snortalog/\2\3:' \
+ -e 's:Can access:Cannot access:' \
+ snortalog.pl || die
+}
+
+src_install () {
+ dobin snortalog.pl
+
+ insinto /etc/snortalog
+ doins conf/{domains,hw,lang,rules}
+
+ insinto /etc/snortalog/picts
+ doins picts/*
+
+ insinto /usr/lib/snortalog/${PV}/modules
+ doins -r modules/*
+
+ dodoc CHANGES doc/snortalog_v2.2.1.pdf
+}