summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl-ttf')
-rw-r--r--media-libs/sdl-ttf/Manifest1
-rw-r--r--media-libs/sdl-ttf/files/sdl-ttf-2.0.11-underlink.patch10
-rw-r--r--media-libs/sdl-ttf/metadata.xml10
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.11-r1.ebuild49
4 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/sdl-ttf/Manifest b/media-libs/sdl-ttf/Manifest
new file mode 100644
index 000000000000..39ae90ecbfc9
--- /dev/null
+++ b/media-libs/sdl-ttf/Manifest
@@ -0,0 +1 @@
+DIST SDL_ttf-2.0.11.tar.gz 4053686 SHA256 724cd895ecf4da319a3ef164892b72078bd92632a5d812111261cde248ebcdb7 SHA512 64e04d1cd77e525e0f2413ad928841e5d3d09d551c030fc577b50777116580e430cb272b2aeb6191dfcc464669cf2f7a5a50d10e7c75637a3b1e8c8fca7fc78b WHIRLPOOL 41a28ded747de5d844878c1ba58bdaed972fa7fd1d8b0d1844ec8a98b4b3f0eb252e6667d53b5d417ffee1f3a6744879f7eddd67751ef24cfdf99429be4279f1
diff --git a/media-libs/sdl-ttf/files/sdl-ttf-2.0.11-underlink.patch b/media-libs/sdl-ttf/files/sdl-ttf-2.0.11-underlink.patch
new file mode 100644
index 000000000000..136589ec7f13
--- /dev/null
+++ b/media-libs/sdl-ttf/files/sdl-ttf-2.0.11-underlink.patch
@@ -0,0 +1,10 @@
+--- Makefile.am.old 2011-05-17 17:17:18.972003301 +0200
++++ Makefile.am 2011-05-17 17:18:38.281983708 +0200
+@@ -33,6 +33,7 @@
+ -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+ endif
++libSDL_ttf_la_LIBADD = @MATHLIB@
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = SDL_ttf.pc
diff --git a/media-libs/sdl-ttf/metadata.xml b/media-libs/sdl-ttf/metadata.xml
new file mode 100644
index 000000000000..24f70e6408cb
--- /dev/null
+++ b/media-libs/sdl-ttf/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+This is a sample library which allows you to use TrueType fonts in your SDL applications. It
+comes with an example program "showfont" which displays an example string for a given
+TrueType font file.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.11-r1.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.11-r1.ebuild
new file mode 100644
index 000000000000..4b4e6bb75a16
--- /dev/null
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.11-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="static-libs X"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ use static-libs || prune_libtool_files --all
+}