summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/Manifest1
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.16.0-endian.patch40
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.16.0-fc_cachedir.patch30
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.16.0-macro-preprocess.patch12
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.16.0-network-test.patch15
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.16.0-pthread.patch37
-rw-r--r--media-libs/fontconfig/fontconfig-2.16.0.ebuild243
7 files changed, 378 insertions, 0 deletions
diff --git a/media-libs/fontconfig/Manifest b/media-libs/fontconfig/Manifest
index 77d112707da0..a549ec7e0e44 100644
--- a/media-libs/fontconfig/Manifest
+++ b/media-libs/fontconfig/Manifest
@@ -1,2 +1,3 @@
DIST fontconfig-2.14.2.tar.xz 1440844 BLAKE2B 4efeeb7f9a6705d493128d00b60e681a20a47556f4c0d7787a5c7a6d2cbbc22f150cad7988a9836a9e72aeb61e2b6a196c00a071c7042c62283c7720cdbb743d SHA512 23483e0ae6aa7589fd37f9949a4cf951c5bff981739dbb446881e4cea86a208c0ab31e2358666eac724af1dc6a689a42733a7ce91cd3e76d8d91eacedb318085
DIST fontconfig-2.15.0.tar.xz 1447820 BLAKE2B 17c85fddc4ab84111c4f50afb89ecd8792c3aeaa2690b38fd39fca6f6cece69e9ce0cd3af8a2e54968c79ad1f9bee1e444699a13c068d9dfd3dfe1212ff37533 SHA512 754cd5fffa198fc07a39cf7df683e9adfa7f54ab41fdff8c0eacc078fd35d3e01069ba343f2b045e0b40df88d9f1fc1ee0f7565799f9cb194a59cf95b64c4417
+DIST fontconfig-2.16.0.tar.xz 1294156 BLAKE2B 48d6fcbfe83f0a4c026a4f90d864a4195805e04cc6dd486bd18d68caa8b55fd51fc37822781298152d363b70dc103c9f8b216f6dc0193b2b192eb35565482ec4 SHA512 90b5c39e5eadc56a9fbddd69b2a6eaa6bf9ee5cda003091b0896e66f87f3c1be8ab4442f54d20fca7232d72f60d9578f5e5ba3f376e39b64b8a2aa7b8f13b062
diff --git a/media-libs/fontconfig/files/fontconfig-2.16.0-endian.patch b/media-libs/fontconfig/files/fontconfig-2.16.0-endian.patch
new file mode 100644
index 000000000000..744208f84e0f
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.16.0-endian.patch
@@ -0,0 +1,40 @@
+https://gitlab.freedesktop.org/fontconfig/fontconfig/-/commit/7c082953381038d5c35820cba939047d708bbb5a
+
+From 7c082953381038d5c35820cba939047d708bbb5a Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Mon, 27 Jan 2025 11:24:19 +0900
+Subject: [PATCH] meson: set WORDS_BIGENDIAN
+
+Fixes https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/446
+---
+ meson.build | 1 +
+ src/fcmd5.h | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 9e9993a2..5aacfc5e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -181,6 +181,7 @@ conf.set_quoted('PACKAGE_VERSION', meson.project_version())
+ conf.set_quoted('PACKAGE_STRING', '@0@ @1@'.format(meson.project_name(), meson.project_version()))
+ conf.set_quoted('PACKAGE_BUGREPORT', 'https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/new')
+ conf.set_quoted('PACKAGE_URL', '')
++conf.set('WORDS_BIGENDIAN', (host_machine.endian() == 'big').to_int())
+
+ if host_machine.system() == 'windows'
+ conf.set('EXEEXT', '.exe')
+diff --git a/src/fcmd5.h b/src/fcmd5.h
+index 7e8a6e1e..bf507285 100644
+--- a/src/fcmd5.h
++++ b/src/fcmd5.h
+@@ -27,7 +27,7 @@ static void MD5Update(struct MD5Context *ctx, const unsigned char *buf, unsigned
+ static void MD5Final(unsigned char digest[16], struct MD5Context *ctx);
+ static void MD5Transform(FcChar32 buf[4], FcChar32 in[16]);
+
+-#ifndef WORDS_BIGENDIAN
++#if !defined(WORDS_BIGENDIAN) || !WORDS_BIGENDIAN
+ #define byteReverse(buf, len) /* Nothing */
+ #else
+ /*
+--
+GitLab
diff --git a/media-libs/fontconfig/files/fontconfig-2.16.0-fc_cachedir.patch b/media-libs/fontconfig/files/fontconfig-2.16.0-fc_cachedir.patch
new file mode 100644
index 000000000000..74d6fadbe2e9
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.16.0-fc_cachedir.patch
@@ -0,0 +1,30 @@
+https://gitlab.freedesktop.org/fontconfig/fontconfig/-/commit/9b864e8ceb480c31cd76ce3fe1d6215f8655ec55
+
+From 9b864e8ceb480c31cd76ce3fe1d6215f8655ec55 Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Mon, 20 Jan 2025 12:08:36 +0900
+Subject: [PATCH] meson: create fc_cachedir at the installation time
+
+Fixes https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/445
+---
+ meson.build | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 4439758d..85968b29 100644
+--- a/meson.build
++++ b/meson.build
+@@ -550,6 +550,11 @@ if not meson.is_subproject()
+ meson.add_dist_script('build-aux/meson-dist-autotools.py')
+ endif
+
++if host_machine.system() != 'windows'
++ install_emptydir(fc_cachedir,
++ install_tag: 'runtime')
++endif
++
+ # Summary
+ doc_targets = get_variable('doc_targets', [])
+
+--
+GitLab
diff --git a/media-libs/fontconfig/files/fontconfig-2.16.0-macro-preprocess.patch b/media-libs/fontconfig/files/fontconfig-2.16.0-macro-preprocess.patch
new file mode 100644
index 000000000000..28d7ab95f829
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.16.0-macro-preprocess.patch
@@ -0,0 +1,12 @@
+https://github.com/mesonbuild/meson/issues/14201
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -29,7 +29,7 @@ fc_sources = [
+ 'ftglue.c',
+ ]
+
+-fcobjshash_h = cc.preprocess('fcobjshash.gperf.h', include_directories: incbase)
++fcobjshash_h = cc.preprocess('fcobjshash.gperf.h', include_directories: incbase, compile_args: '-g0')
+ fcobjshash_gperf = custom_target(
+ input: fcobjshash_h,
+ output: 'fcobjshash.gperf',
diff --git a/media-libs/fontconfig/files/fontconfig-2.16.0-network-test.patch b/media-libs/fontconfig/files/fontconfig-2.16.0-network-test.patch
new file mode 100644
index 000000000000..890d25f4f16b
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.16.0-network-test.patch
@@ -0,0 +1,15 @@
+If pytest is found, it tries to use pytest-tap (which is currently unpackaged).
+
+But as of fontconfig-2.16.0, this only runs test_issue431.py which needs
+network access, so we can't run it anyway. Stub it out.
+--- a/test/meson.build
++++ b/test/meson.build
+@@ -61,7 +61,7 @@ if host_machine.system() != 'windows'
+
+ test('run_test_sh', find_program('run-test.sh'), timeout: 600, env: ['srcdir=@0@'.format(meson.current_source_dir()), 'builddir=@0@'.format(meson.current_build_dir()), 'EXEEXT=@0@'.format(conf.get('EXEEXT')), 'VERBOSE=1'])
+
+- if pytest.found()
++ if false
+ test('pytest', pytest, args: ['--tap'],
+ workdir: meson.current_source_dir(),
+ env: ['builddir=@0@'.format(meson.current_build_dir())],
diff --git a/media-libs/fontconfig/files/fontconfig-2.16.0-pthread.patch b/media-libs/fontconfig/files/fontconfig-2.16.0-pthread.patch
new file mode 100644
index 000000000000..df68082cca6e
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.16.0-pthread.patch
@@ -0,0 +1,37 @@
+https://gitlab.freedesktop.org/fontconfig/fontconfig/-/commit/aad470dad519b6fe3459023b82941b4414b71313
+
+From aad470dad519b6fe3459023b82941b4414b71313 Mon Sep 17 00:00:00 2001
+From: Thomas Devoogdt <thomas@devoogdt.com>
+Date: Sun, 26 Jan 2025 10:15:39 +0100
+Subject: [PATCH] meson.build: explicitly check for pthread support
+
+Tested using buildroot. The br-arm-full-nothread fails
+because meson assumes thread support when cross-compiling.
+
+Dependency threads found: YES unknown (cached)
+Has header "pthread.h" : NO
+
+Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
+---
+ meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 85968b29..9e9993a2 100644
+--- a/meson.build
++++ b/meson.build
+@@ -383,8 +383,10 @@ endif
+
+ if host_machine.system() != 'windows'
+ thread_dep = dependency('threads')
+- conf.set('HAVE_PTHREAD', 1)
+- deps += [thread_dep]
++ if thread_dep.found() and cc.has_header('pthread.h')
++ conf.set('HAVE_PTHREAD', 1)
++ deps += [thread_dep]
++ endif
+ endif
+
+ fc_templatedir = get_option('template-dir')
+--
+GitLab
diff --git a/media-libs/fontconfig/fontconfig-2.16.0.ebuild b/media-libs/fontconfig/fontconfig-2.16.0.ebuild
new file mode 100644
index 000000000000..71ab244159db
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.16.0.ebuild
@@ -0,0 +1,243 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit multilib meson-multilib python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="https://fontconfig.org/"
+SRC_URI="https://fontconfig.org/release/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="1.0"
+if ! [[ $(ver_cut 3) -ge 90 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+IUSE="doc nls test"
+RESTRICT="!test? ( test )"
+
+# - Check minimum freetype & other deps on bumps. See
+# https://gitlab.freedesktop.org/fontconfig/fontconfig/-/blob/main/configure.ac#L314.
+# Note that FT versioning is confusing, need to map it using
+# https://git.savannah.gnu.org/cgit/freetype/freetype2.git/tree/docs/VERSIONS.TXT
+# But sometimes it's actually greater than that, e.g. see Fedora's spec file
+# https://src.fedoraproject.org/rpms/fontconfig/blob/rawhide/f/fontconfig.spec#_1
+#
+# - Purposefully dropped the xml USE flag and libxml2 support. Expat is the
+# default and used by every distro. See bug #283191.
+#
+# - There's a test-only dep on json-c.
+# It might become an optional(?) runtime dep in future though. Who knows.
+# Keep an eye on it.
+RDEPEND="
+ >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9.1[${MULTILIB_USEDEP}]
+ virtual/libintl[${MULTILIB_USEDEP}]
+ !elibc_Darwin? ( !elibc_SunOS? ( sys-apps/util-linux[${MULTILIB_USEDEP}] ) )
+ elibc_Darwin? ( sys-libs/native-uuid )
+ elibc_SunOS? ( sys-libs/libuuid )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/json-c )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-build/meson-1.6.0
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? (
+ =app-text/docbook-sgml-dtd-3.1*
+ app-text/docbook-sgml-utils[jadetex]
+ )
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+PDEPEND="virtual/ttf-fonts"
+# We need app-eselect/eselect-fontconfig in IDEPEND to update ROOT
+# when cross-compiling.
+IDEPEND="app-eselect/eselect-fontconfig"
+
+PATCHES=(
+ # bug #130466 + make liberation default
+ "${FILESDIR}"/${PN}-2.14.0-latin-update.patch
+ # Avoid test failure (bubblewrap doesn't work within sandbox)
+ "${FILESDIR}"/${PN}-2.14.0-skip-bubblewrap-tests.patch
+ # Avoid network access and unpackaged pytest-tap
+ "${FILESDIR}"/${PN}-2.16.0-network-test.patch
+
+ # Patches from upstream (can usually be removed with next version bump)
+ "${FILESDIR}"/${P}-fc_cachedir.patch
+ "${FILESDIR}"/${P}-pthread.patch
+ "${FILESDIR}"/${P}-endian.patch
+ "${FILESDIR}"/${PN}-2.16.0-macro-preprocess.patch
+)
+
+DOC_CONTENTS="Please make fontconfig configuration changes using
+\`eselect fontconfig\`. Any changes made to /etc/fonts/fonts.conf will be
+overwritten. If you need to reset your configuration to upstream defaults,
+delete the directory ${EROOT}/etc/fonts/conf.d/ and re-emerge fontconfig."
+
+src_prepare() {
+ default
+
+ # Test needs network access
+ # https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/319
+ # On bumps, please check to see if this has been fixed
+ # to allow local access!
+ sed -i -e '/test-crbug1004254/d' test/meson.build || die
+}
+
+multilib_src_configure() {
+ local addfonts=(
+ "${EPREFIX}"/usr/local/share/fonts
+ )
+
+ # Harvest some font locations, such that users can benefit from the
+ # host OS's installed fonts
+ case ${CHOST} in
+ *-darwin*)
+ addfonts+=(
+ /Library/Fonts
+ /System/Library/Fonts
+ )
+ ;;
+
+ *-solaris*)
+ [[ -d /usr/X/lib/X11/fonts/TrueType ]] && \
+ addfonts+=( /usr/X/lib/X11/fonts/TrueType )
+ [[ -d /usr/X/lib/X11/fonts/Type1 ]] &&
+ addfonts+=( /usr/X/lib/X11/fonts/Type1 )
+ ;;
+
+ *-linux-gnu)
+ use prefix && [[ -d /usr/share/fonts ]] && \
+ addfonts+=( /usr/share/fonts )
+ ;;
+ esac
+
+ local emesonargs=(
+ # USE=doc only controls the additional bits like html/pdf
+ # and regeneration of man pages from source. We always install
+ # the prebuilt man pages.
+ $(meson_native_use_feature doc)
+ $(meson_native_use_feature doc doc-txt)
+ $(meson_native_use_feature doc doc-html)
+ $(meson_native_use_feature doc doc-man)
+ $(meson_native_use_feature doc doc-pdf)
+
+ $(meson_native_use_feature nls)
+ $(meson_feature test tests)
+
+ -Dcache-build=disabled
+ -Dcache-dir="${EPREFIX}"/var/cache/fontconfig
+ -Ddefault-fonts-dirs="${EPREFIX}"/usr/share/fonts
+ -Dadditional-fonts-dirs=$(IFS=, ; echo "${addfonts[*]}" )
+ -Dtemplate-dir="${EPREFIX}"/etc/fonts/conf.avail
+ # TODO: Rust
+ -Dfontations=disabled
+ -Dxml-backend=expat
+
+ # Let users choose via eselect-fontconfig. See bug #900681
+ # and https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/356.
+ -Ddefault-sub-pixel-rendering=none
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install() {
+ MULTILIB_CHOST_TOOLS=( /usr/bin/fc-cache$(get_exeext) )
+
+ meson_src_install
+
+ rm -rf "${ED}"/var/cache || die
+
+ # Avoid calling this multiple times, bug #459210
+ if multilib_is_native_abi; then
+ insinto /etc/fonts
+ doins fonts.conf
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # fc-lang directory contains language coverage datafiles
+ # which are needed to test the coverage of fonts.
+ insinto /usr/share/fc-lang
+ doins fc-lang/*.orth
+
+ dodoc doc/fontconfig-user.{txt,pdf}
+
+ if ! use doc ; then
+ find "${S}" -name "*.[[:digit:]]" -type f -exec doman '{}' + || die
+ fi
+
+ if [[ -e ${ED}/usr/share/doc/fontconfig/ ]] ; then
+ mv "${ED}"/usr/share/doc/fontconfig/* "${ED}"/usr/share/doc/${PF} || die
+ rm -rf "${ED}"/usr/share/doc/fontconfig || die
+ fi
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf we force update it ...
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig || die
+ doenvd "${T}"/37fontconfig
+
+ # As of fontconfig 2.7, everything sticks their noses in here.
+ dodir /etc/sandbox.d
+ echo 'SANDBOX_PREDICT="/var/cache/fontconfig"' > "${ED}"/etc/sandbox.d/37fontconfig || die
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # bug #193476
+ # /etc/fonts/conf.d/ contains symlinks to ../conf.avail/ to include various
+ # config files. If we install as-is, we'll blow away user settings.
+ ebegin "Syncing fontconfig configuration to system"
+ if [[ -e ${EROOT}/etc/fonts/conf.d ]] ; then
+ local file f
+ for file in "${EROOT}"/etc/fonts/conf.avail/* ; do
+ f=${file##*/}
+ if [[ -L ${EROOT}/etc/fonts/conf.d/${f} ]] ; then
+ [[ -f ${ED}/etc/fonts/conf.avail/${f} ]] \
+ && ln -sf ../conf.avail/"${f}" \
+ "${ED}"/etc/fonts/conf.d/ &>/dev/null
+ else
+ [[ -f ${ED}/etc/fonts/conf.avail/${f} ]] \
+ && rm "${ED}"/etc/fonts/conf.d/"${f}" &>/dev/null
+ fi
+ done
+ fi
+ eend $?
+}
+
+pkg_postinst() {
+ einfo "Cleaning broken symlinks in ${EROOT}/etc/fonts/conf.d/"
+ find -L "${EROOT}"/etc/fonts/conf.d/ -type l -delete
+
+ readme.gentoo_print_elog
+
+ local ver
+ for ver in ${REPLACING_VERSIONS} ; do
+ # 2.14.2 and 2.14.2-r1 included the bad 10-sub-pixel-none.conf
+ if ver_test ${ver} -lt 2.14.2-r2 && ver_test ${ver} -ge 2.14.2 ; then
+ if [[ -e "${EROOT}"/etc/fonts/conf.d/10-sub-pixel-none.conf ]] ; then
+ einfo "Deleting 10-sub-pixel-none.conf from bad fontconfig-2.14.2 (bug #900681)"
+ rm "${EROOT}"/etc/fonts/conf.d/10-sub-pixel-none.conf || die
+ fi
+ fi
+ done
+
+ if [[ -z ${ROOT} ]] ; then
+ multilib_pkg_postinst() {
+ ebegin "Creating global font cache for ${ABI}"
+ "${EPREFIX}"/usr/bin/${CHOST}-fc-cache -srf
+ eend $?
+ }
+
+ multilib_parallel_foreach_abi multilib_pkg_postinst
+ fi
+}