summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/catcodec/catcodec-1.0.5.ebuild')
-rw-r--r--games-util/catcodec/catcodec-1.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-util/catcodec/catcodec-1.0.5.ebuild b/games-util/catcodec/catcodec-1.0.5.ebuild
new file mode 100644
index 000000000000..dd3a0c53bede
--- /dev/null
+++ b/games-util/catcodec/catcodec-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
+HOMEPAGE="http://www.openttd.org/en/download-catcodec"
+SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ tc-export CXX
+}
+
+src_compile() {
+ emake VERBOSE=1
+}
+
+src_install() {
+ dobin catcodec
+ dodoc changelog.txt docs/readme.txt
+ doman docs/catcodec.1
+}