summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/drone/drone-0.5.0_p20170316.ebuild')
-rw-r--r--dev-util/drone/drone-0.5.0_p20170316.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/drone/drone-0.5.0_p20170316.ebuild b/dev-util/drone/drone-0.5.0_p20170316.ebuild
new file mode 100644
index 000000000000..1f5b9b0d77e9
--- /dev/null
+++ b/dev-util/drone/drone-0.5.0_p20170316.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_PN="github.com/drone/drone/..."
+EGIT_COMMIT="e03d3d9932b37ebac21514de24d926f0478a9e60"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A Continuous Delivery platform built on Docker, written in Go"
+HOMEPAGE="https://github.com/drone/drone"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata
+ dev-go/go-bindata-assetfs:=
+ dev-util/drone-ui:="
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/github.com/drone/drone gen || die
+ pushd src || die
+ DRONE_BUILD_NUMBER="${EGIT_COMMIT:0:7}" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)"\
+ go install -ldflags "-extldflags '-static' -X github.com/drone/drone/version.VersionDev=${EGIT_COMMIT:0:7}" github.com/drone/drone/drone || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+}