summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyx')
-rw-r--r--dev-python/pyx/Manifest3
-rw-r--r--dev-python/pyx/metadata.xml14
-rw-r--r--dev-python/pyx/pyx-0.12.1-r1.ebuild47
-rw-r--r--dev-python/pyx/pyx-0.13.ebuild47
-rw-r--r--dev-python/pyx/pyx-0.14.ebuild47
5 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/pyx/Manifest b/dev-python/pyx/Manifest
new file mode 100644
index 000000000000..c91a569c5723
--- /dev/null
+++ b/dev-python/pyx/Manifest
@@ -0,0 +1,3 @@
+DIST PyX-0.12.1.tar.gz 561989 SHA256 e837b26a8b1c27524cf3f3dd6c0d563451249159edaa2e366d87e7143a867e8e SHA512 4941f5aa21aff3743546495fb073c10d2657ff42b2aff401903498638093d0e31e344cce778980f28a7170c6d29eab72ac074277b9d4088376e8692dc71e55c1 WHIRLPOOL a4d4a21e78b72841ca38dea87296d21f0bc8255e428cb0733fbee9d71c3bfb031d8a9f9fff988dbf0e2af7222553918a9aa924769891c50beb607c6ce3fe2fa4
+DIST PyX-0.13.tar.gz 1237082 SHA256 1952962c965000d8e04a00d1b85c600cdef4588cea88c9face2adbedf21d42c6 SHA512 cab0c22f0862ae20cff92504ededf4fcf5820d5773130fb258de1a95d295ca4fe657b85d5ccd52021a4f84403e6db8eebe9f676fa405781738502456123eb05c WHIRLPOOL 0a6159cd5f2683c70b33aac71278ad6f0df3ae54897d0ab31a9b61897be9b4e531cc41c7772a60a152b3b7a39d383ba669be7401c503704f14cbbf3ceca25c41
+DIST PyX-0.14.tar.gz 2475559 SHA256 b0ea832e97156338010767a7edacbf6147a75cdd5ac1b147bd73afd514eed370 SHA512 328b917e406e29f656dff00ff54fc5b82296cdc4b134f45ef380d0b1e7011311e4c149be59f5089064c183e8ade3adca27a2304b3bafd2e735f256e6de8b8b3b WHIRLPOOL 34ee7b2723618a493d15e2509456e1539acfc9d0010a202c14ba353505ef1394c753cfc083b557d0250918e501d9931dc7949ec6f623b00be63d16a5e3db6839
diff --git a/dev-python/pyx/metadata.xml b/dev-python/pyx/metadata.xml
new file mode 100644
index 000000000000..d580ab0df219
--- /dev/null
+++ b/dev-python/pyx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+PyX is a Python package for the creation of encapsulated PostScript figures.
+It provides both an abstraction of PostScript and a TeX/LaTeX interface.
+Complex tasks like 2d and 3d plots in publication-ready quality are built out
+of these primitives.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyx/pyx-0.12.1-r1.ebuild b/dev-python/pyx/pyx-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..6530d407f75d
--- /dev/null
+++ b/dev-python/pyx/pyx-0.12.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base
+ dev-texlive/texlive-basic"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake -C "${S}"/faq latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc faq/_build/latex/pyxfaq.pdf
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyx/pyx-0.13.ebuild b/dev-python/pyx/pyx-0.13.ebuild
new file mode 100644
index 000000000000..116e8c04ef4e
--- /dev/null
+++ b/dev-python/pyx/pyx-0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base
+ dev-texlive/texlive-basic"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake -C "${S}"/faq latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc faq/_build/latex/pyxfaq.pdf
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyx/pyx-0.14.ebuild b/dev-python/pyx/pyx-0.14.ebuild
new file mode 100644
index 000000000000..766445040864
--- /dev/null
+++ b/dev-python/pyx/pyx-0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base
+ dev-texlive/texlive-basic"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake -C "${S}"/faq latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc faq/_build/latex/pyxfaq.pdf
+ distutils-r1_python_install_all
+}