summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild')
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild b/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..f9b5040f1568
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl.
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx "docs/source"
+
+python_prepare_all() {
+ # too many dependencies
+ rm tests/pandas_test.py || die
+ sed -e '/pandas/ d' -i tests/runtests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
+ einfo "testsuite has optional tests for package demjson"
+ "${EPYTHON}" tests/runtests.py || die "tests failed with ${EPYTHON}"
+}