summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/grpcio-tools/grpcio-tools-1.17.0.ebuild')
-rw-r--r--dev-python/grpcio-tools/grpcio-tools-1.17.0.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/grpcio-tools/grpcio-tools-1.17.0.ebuild b/dev-python/grpcio-tools/grpcio-tools-1.17.0.ebuild
deleted file mode 100644
index e7664411391f..000000000000
--- a/dev-python/grpcio-tools/grpcio-tools-1.17.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="Protobuf code generator for gRPC"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/cython[${PYTHON_USEDEP}]
- ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- !<net-libs/grpc-1.16.0[tools]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_compile() {
- export GRPC_PYTHON_BUILD_WITH_CYTHON=1
- distutils-r1_python_compile
-}