summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild')
-rw-r--r--dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild b/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
index 01f0536d3ea1..ea3b7a6b6f98 100644
--- a/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
+++ b/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
@@ -22,6 +22,13 @@ DEPEND="
test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
RDEPEND=""
+PATCHES=(
+ # This patch disables some tests for pypy as they do not work as expected.
+ # This has been reported upstream
+ # https://github.com/testing-cabal/funcsigs/issues/10
+ "${FILESDIR}/${P}-fix-pypy3-tests.patch"
+)
+
python_test() {
esetup.py test
}