summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fastbencode/fastbencode-0.2.ebuild')
-rw-r--r--dev-python/fastbencode/fastbencode-0.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/fastbencode/fastbencode-0.2.ebuild b/dev-python/fastbencode/fastbencode-0.2.ebuild
index f884ac6d4ab5..068bcff75e2d 100644
--- a/dev-python/fastbencode/fastbencode-0.2.ebuild
+++ b/dev-python/fastbencode/fastbencode-0.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -25,6 +25,11 @@ BDEPEND="
distutils_enable_tests unittest
+PATCHES=(
+ # https://github.com/breezy-team/fastbencode/commit/23e8cadcc81c6649d96742f235a98bd3047e5d8a
+ "${FILESDIR}"/${P}-py312.patch
+)
+
python_test() {
cd fastbencode/tests || die
eunittest