summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cssutils/cssutils-1.0.1.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-1.0.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.1.ebuild b/dev-python/cssutils/cssutils-1.0.1.ebuild
deleted file mode 100644
index f3e9e622067b..000000000000
--- a/dev-python/cssutils/cssutils-1.0.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-pypy-test-backport.patch
-)
-
-python_prepare_all() {
- # Disable test failing with dev-python/pyxml installed.
- if has_version dev-python/pyxml; then
- sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
- fi
-
- # requires old pbr, does it really?
- sed \
- -e '/tests_require/d' \
- -i setup.py || die
-
- EPATCH_OPTS="--binary"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
- # esetup.py test
- # exclude tests that connect to the network
- set -- nosetests \
- -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
- echo "$@"
- "$@" || die "Testing failed with ${EPYTHON}"
-}