summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.10.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.10.2.ebuild b/dev-python/Babel/Babel-2.10.2.ebuild
index 956741a0f462..af5ed2211ba1 100644
--- a/dev-python/Babel/Babel-2.10.2.ebuild
+++ b/dev-python/Babel/Babel-2.10.2.ebuild
@@ -44,6 +44,14 @@ BDEPEND="
distutils_enable_sphinx docs
distutils_enable_tests pytest
+python_check_deps() {
+ if [[ ${EPYTHON} == python3.8 ]] ; then
+ python_has_version "dev-python/backports-zoneinfo[${PYTHON_USEDEP}]" || return 1
+ fi
+
+ python_has_version "dev-python/pytz[${PYTHON_USEDEP}]"
+}
+
python_configure_all() {
rm babel/locale-data/*.dat || die
rm babel/global.dat || die