summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Module-Pluggable/Module-Pluggable-6.200.0.ebuild')
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-6.200.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-6.200.0.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-6.200.0.ebuild
new file mode 100644
index 000000000000..969e296ebffc
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-6.200.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SIMONW
+DIST_VERSION=6.2
+inherit perl-module
+
+DESCRIPTION="Automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-3
+ virtual/perl-if
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"