summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-18.1.0.20240926.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-18.1.0.20240926.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-18.1.0.20240926.ebuild b/dev-lisp/c2ffi/c2ffi-18.1.0.20240926.ebuild
new file mode 100644
index 000000000000..9a88c30ee22e
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-18.1.0.20240926.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_MAX_SLOT=18
+inherit cmake llvm
+
+MY_COMMIT="0de81efb64acc82c08c5eee4a7108ddcb1b00d86"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAX_SLOT}"
+RDEPEND="${DEPEND}"