summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xml-commons-external/xml-commons-external-1.4.01-r1.ebuild')
-rw-r--r--dev-java/xml-commons-external/xml-commons-external-1.4.01-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/xml-commons-external/xml-commons-external-1.4.01-r1.ebuild b/dev-java/xml-commons-external/xml-commons-external-1.4.01-r1.ebuild
new file mode 100644
index 000000000000..f87c527c62e4
--- /dev/null
+++ b/dev-java/xml-commons-external/xml-commons-external-1.4.01-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="xml-apis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Externally-defined set of standard interfaces, namely DOM, SAX, and JAXP"
+HOMEPAGE="http://xerces.apache.org/xml-commons/components/external/"
+SRC_URI="https://repo1.maven.org/maven2/${MY_PN}/${MY_PN}/${PV}/${MY_P}-sources.jar -> ${P}.jar"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="1.4"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"