summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/asm/asm-5.0.4.ebuild')
-rw-r--r--dev-java/asm/asm-5.0.4.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-java/asm/asm-5.0.4.ebuild b/dev-java/asm/asm-5.0.4.ebuild
deleted file mode 100644
index 414109a8832c..000000000000
--- a/dev-java/asm/asm-5.0.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-OLD_P="${PN}-4.0"
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Bytecode manipulation framework for Java"
-HOMEPAGE="http://asm.ow2.org"
-SRC_URI="http://download.forge.objectweb.org/${PN}/${P}.tar.gz
- http://download.forge.objectweb.org/${PN}/${OLD_P}.tar.gz"
-LICENSE="BSD"
-SLOT="4"
-IUSE=""
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-fbsd ~x64-macos"
-
-DEPEND=">=virtual/jdk-1.6"
-RDEPEND=">=virtual/jre-1.6"
-
-# Needs dependencies we don't have yet.
-RESTRICT="test"
-
-EANT_DOC_TARGET="jdoc"
-
-# Fails if this objectweb.ant.tasks.path is not set.
-# Java generics seem to break unless product.noshrink is set.
-EANT_EXTRA_ARGS="-Dobjectweb.ant.tasks.path=foobar -Dproduct.noshrink=true"
-
-java_prepare() {
- # Borrow some ant scripts from an old version to avoid requiring
- # bndlib and friends. This may not work forever!
- cp -vf "../${OLD_P}/archive"/*.xml archive/ || die
-}
-
-src_install() {
- for x in output/dist/lib/*.jar ; do
- java-pkg_newjar "${x}" $(basename "${x%-*}.jar")
- done
-
- use doc && java-pkg_dojavadoc output/dist/doc/javadoc/user/
- use source && java-pkg_dosrc src/*
-}