summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/warp/warp-2.0.3.3.ebuild')
-rw-r--r--dev-haskell/warp/warp-2.0.3.3.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-haskell/warp/warp-2.0.3.3.ebuild b/dev-haskell/warp/warp-2.0.3.3.ebuild
deleted file mode 100644
index 3c180f2ec614..000000000000
--- a/dev-haskell/warp/warp-2.0.3.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.6.9999
-#hackport: flags: -network-bytestring
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A fast, light-weight web server for WAI applications"
-HOMEPAGE="https://github.com/yesodweb/wai"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+allow-sendfilefd"
-RESTRICT="test"
-
-RDEPEND=">=dev-haskell/blaze-builder-0.3.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
- >=dev-haskell/blaze-builder-conduit-0.5:=[profile?] <dev-haskell/blaze-builder-conduit-1.1:=[profile?]
- >=dev-haskell/case-insensitive-0.2:=[profile?]
- >=dev-haskell/conduit-0.5:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
- dev-haskell/http-date:=[profile?]
- >=dev-haskell/http-types-0.7:=[profile?]
- >=dev-haskell/lifted-base-0.1:=[profile?]
- >=dev-haskell/network-2.3:=[profile?]
- >=dev-haskell/network-conduit-0.5:=[profile?] <dev-haskell/network-conduit-1.1:=[profile?]
- >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
- >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
- >=dev-haskell/unix-compat-0.2:=[profile?]
- dev-haskell/void:=[profile?]
- >=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.1:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- allow-sendfilefd? ( dev-haskell/hashable:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/doctest-0.9.3
- >=dev-haskell/hspec-1.3
- dev-haskell/http
- dev-haskell/hunit
- dev-haskell/quickcheck )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag allow-sendfilefd allow-sendfilefd) \
- --flag=-network-bytestring
-}