summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashable')
-rw-r--r--dev-haskell/hashable/Manifest5
-rw-r--r--dev-haskell/hashable/hashable-1.1.2.5.ebuild29
-rw-r--r--dev-haskell/hashable/hashable-1.2.1.0.ebuild43
-rw-r--r--dev-haskell/hashable/hashable-1.2.3.1.ebuild41
-rw-r--r--dev-haskell/hashable/hashable-1.2.3.2.ebuild40
-rw-r--r--dev-haskell/hashable/hashable-1.2.3.3.ebuild40
-rw-r--r--dev-haskell/hashable/metadata.xml15
7 files changed, 213 insertions, 0 deletions
diff --git a/dev-haskell/hashable/Manifest b/dev-haskell/hashable/Manifest
new file mode 100644
index 000000000000..52220ecf3b7f
--- /dev/null
+++ b/dev-haskell/hashable/Manifest
@@ -0,0 +1,5 @@
+DIST hashable-1.1.2.5.tar.gz 9129 SHA256 3fb5d430c9289ebada4991a76fd78f028aaaf17957dc666ddc7b89c98a54713d SHA512 dc6acab7a17709ed483bbc22cb7e29f5518e34102e6ffddbac4dabc2a854d595cf7517fc776e47e55d41c23107636b796150804ef8099dd4545e33f6df1ab0b6 WHIRLPOOL 9de525387fb8fdf9a6262171f15ecec7af4f9592e98782100d75c263137cfc3796156bea90745fdf052ad91c16ce216cfb5594dce0de20528a60486ced8b7ad9
+DIST hashable-1.2.1.0.tar.gz 22389 SHA256 4ec07479fe37174e694b8d54cfc2111648e325fd1d7dce92366ed4ce2e7da126 SHA512 343f6b9eb40d089f0f2187427af7d7b5dbe15884649ddc8e0b140db129f21fc44f6bf41a262a3b2a0c74d967be6f603799472802d835e48a442f836dd8142607 WHIRLPOOL 7c8d174b48b5124f6cc52151d3d47f3da22adf61525a080048eee5ee4aa54598adccd2d189979c3631d72ce2c9312505ec3991748276058342c59e450f1f92fe
+DIST hashable-1.2.3.1.tar.gz 23845 SHA256 d5bf53df132e56671a3a4533c89324b327e1b47181b3961cffa87f5aea6f7af9 SHA512 e8518490a89aa42c283adbda038754a2d0ad4ebcf9c28fa5203be69616f9c6d12befd472874d34e3892d70cfa6de6e0f5be9dddae9b78a8fdfb83106074825d3 WHIRLPOOL 7ae107a0bf4710b1d558a3eaa05ac0542c29fb4cf8353366fd8afa64fd60cf1ce47cd6dcab7706f5ecbab11186509af88b6786668cae9c9b122f9ba106314ece
+DIST hashable-1.2.3.2.tar.gz 23903 SHA256 8c66fc70f75c5e1eaa8278c2c624a8cf5a73d5127df1cb2956eb69b16f492241 SHA512 e5c646881ebe3c73c598ee4c24f5454524867c823137702ab3010b346ee8dec6b93623834838e43413d19d97c3c011bcc54e915d1055d76f90d2315fc25a600b WHIRLPOOL 0ee669fa904e45ae9d9e279c55e904470646ffc782d5953a27e0f92bc35a0c9b961a552b3a4816d8a5741c38b8f7fd59678cbe81e4ec4ad0b00edef6c05cc3d0
+DIST hashable-1.2.3.3.tar.gz 23944 SHA256 fc923f7d1fdc0062416a61f6ab96b4e1958e1aee1ddf1c71fa2cc6d08154e44e SHA512 f2e693ecdd96591b703f584b501818215379ce56e8fc7591307fe15d2745d1eb7d2ca7c130dde84a66337c81089c783f227f6215d868958caecc58bf996c7a22 WHIRLPOOL 8177001510bf326787f3af676d4f62796bc5371a715ab6beb3604fac77a64eaa74ffda449dfb2c69200afea964b380e549c5c9782ea52c8ced8f32380e1f30a3
diff --git a/dev-haskell/hashable/hashable-1.1.2.5.ebuild b/dev-haskell/hashable/hashable-1.1.2.5.ebuild
new file mode 100644
index 000000000000..d32836d9f072
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-6.10.1:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/quickcheck-2.4.0.1
+ =dev-haskell/random-1.0*
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/hashable/hashable-1.2.1.0.ebuild b/dev-haskell/hashable/hashable-1.2.1.0.ebuild
new file mode 100644
index 000000000000..375759d71f8b
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="+cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.1
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_prepare() {
+ # a workaround for <cabal-1.18 #498480
+ hsc2hs tests/Regress/Mmap.{hsc,hs} || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag cpu_flags_x86_sse2 sse2) \
+ $(cabal_flag cpu_flags_x86_sse4_1 sse41)
+}
diff --git a/dev-haskell/hashable/hashable-1.2.3.1.ebuild b/dev-haskell/hashable/hashable-1.2.3.1.ebuild
new file mode 100644
index 000000000000..f76e9d911dd6
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: sse4_1:sse41 gmp:integer-gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gmp +cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ >=dev-haskell/text-0.11.0.5 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag gmp integer-gmp) \
+ $(cabal_flag cpu_flags_x86_sse2 sse2) \
+ $(cabal_flag cpu_flags_x86_sse4_1 sse41)
+}
diff --git a/dev-haskell/hashable/hashable-1.2.3.2.ebuild b/dev-haskell/hashable/hashable-1.2.3.2.ebuild
new file mode 100644
index 000000000000..05825ff0932c
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+#hackport: flags: -sse2,-sse41,integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gmp"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag gmp integer-gmp) \
+ --flag=-sse2 \
+ --flag=-sse41
+}
diff --git a/dev-haskell/hashable/hashable-1.2.3.3.ebuild b/dev-haskell/hashable/hashable-1.2.3.3.ebuild
new file mode 100644
index 000000000000..060568bbdfae
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -sse2,-sse41,integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gmp"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag gmp integer-gmp) \
+ --flag=-sse2 \
+ --flag=-sse41
+}
diff --git a/dev-haskell/hashable/metadata.xml b/dev-haskell/hashable/metadata.xml
new file mode 100644
index 000000000000..7c06716089c0
--- /dev/null
+++ b/dev-haskell/hashable/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package defines a class, 'Hashable', for types that
+ can be converted to a hash value. This class
+ exists for the benefit of hashing-based data
+ structures. The package provides instances for
+ basic types and a way to combine hash values.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tibbe/hashable</remote-id>
+ </upstream>
+</pkgmetadata>