summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/csv/csv-0.31-r2.ebuild4
-rw-r--r--app-vim/json/json-20150511.ebuild4
-rw-r--r--app-vim/splice/splice-1.1.0-r5.ebuild41
-rw-r--r--app-vim/vimpython/vimpython-1.13-r4.ebuild17
4 files changed, 62 insertions, 4 deletions
diff --git a/app-vim/csv/csv-0.31-r2.ebuild b/app-vim/csv/csv-0.31-r2.ebuild
index ec97dda83232..c790120587e6 100644
--- a/app-vim/csv/csv-0.31-r2.ebuild
+++ b/app-vim/csv/csv-0.31-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,6 +9,6 @@ DESCRIPTION="vim plugin: display and alter csv files"
HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2830"
LICENSE="vim"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~arm64 x86"
VIM_PLUGIN_HELPFILES="ft-csv.txt"
diff --git a/app-vim/json/json-20150511.ebuild b/app-vim/json/json-20150511.ebuild
index cc4a35de61d1..0584747ca35e 100644
--- a/app-vim/json/json-20150511.ebuild
+++ b/app-vim/json/json-20150511.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,6 +8,6 @@ inherit vim-plugin
DESCRIPTION="vim plugin: a better JSON for Vim"
HOMEPAGE="https://github.com/elzr/vim-json/"
LICENSE="MIT"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~arm64 x86"
DOCS=( readme.md )
diff --git a/app-vim/splice/splice-1.1.0-r5.ebuild b/app-vim/splice/splice-1.1.0-r5.ebuild
new file mode 100644
index 000000000000..1f17cfe102f6
--- /dev/null
+++ b/app-vim/splice/splice-1.1.0-r5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://docs.stevelosh.com/splice.vim/
+ https://github.com/sjl/splice.vim
+ https://www.vim.org/scripts/script.php?script_id=4026"
+SRC_URI="https://github.com/sjl/splice.vim/archive/v${PV}.tar.gz -> ${P}-github.tar.gz"
+S=${WORKDIR}/splice.vim-${PV}
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r site || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}
diff --git a/app-vim/vimpython/vimpython-1.13-r4.ebuild b/app-vim/vimpython/vimpython-1.13-r4.ebuild
new file mode 100644
index 000000000000..bbee89cc1b46
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"