summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index a76d023ca1c3..5f3b40bc9757 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -3,3 +3,4 @@ DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289d
DIST compat-29.1.1.0.tar.gz 94072 BLAKE2B 675f0bbf4411fb0d2c2e8f77bcd62dbe56da1f052bd6e390dade0c8075eaa480bb387280a29ae09396a2f4bf27746ae1065d38dd1b7882b9c8c0ec3a4eb776e5 SHA512 5c7b093314cd8f8d8cbab4f470a64d3f104d0e79d2881f2f2309700c6fe5f58a72a8a65379868edba33c0b6af1d43f1474e2fefc65c033f39981d29fca35259a
DIST compat-29.1.1.1.tar.gz 96932 BLAKE2B 69941bc24d5146103d82862214064b11bfdd335d1af48bf776024c4f73fa156b1d953bb7dad902bbf31a957dfa498762377136ea062fbc7aa0d716cc42bc0228 SHA512 d31b5544e703252d97ef8145ce9f1dc3265264d1e1b62ca46e0baf200b6fb839d20701dafccedb22661472678ca4fcb74fa613fe7244e6359504fb67699f18cc
DIST compat-29.1.2.0.tar.gz 98435 BLAKE2B c78a57badb43c527598f2f48bb80a348d2805bb2f0fbec2d76a97b02bcfab5edf48033788f04c9e2b6534471eeff033654bf255202c92200b08a3ebbaa2d2cb3 SHA512 0fadc730d1ae4fda443eff4b3e6a9e49b6b676963d45b08c020b1aa295af9345ec48da082fde651284c52699433e31ef973fe99305614577d325ab9e4059618f
+DIST compat-29.1.3.0.tar.gz 111711 BLAKE2B 7a9b104baf141136e91a49e4697e0add3da64cf979354c25c7798c9a8f1b91796e774f262fc306a12c4c03d918089ca9af48471ab62bb0f02a890969f54104e7 SHA512 5724855f0572b33bd96ea0dfa85eac3b64f6c5be58edc2b14d474295d0b0cd86a0e71d704907aed37d1bb254be938e98ef15323cae590ca10cd072b94d3f25c2
diff --git a/app-emacs/compat/compat-29.1.3.0.ebuild b/app-emacs/compat/compat-29.1.3.0.ebuild
new file mode 100644
index 000000000000..459edf66eea1
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}