summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/burncenter/burncenter-3.2.1.ebuild')
-rw-r--r--app-cdr/burncenter/burncenter-3.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-cdr/burncenter/burncenter-3.2.1.ebuild b/app-cdr/burncenter/burncenter-3.2.1.ebuild
new file mode 100644
index 000000000000..c93b43073859
--- /dev/null
+++ b/app-cdr/burncenter/burncenter-3.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A Perl module and a collection of easy-to-use text based interfaces to the UNIX CD burning tools"
+HOMEPAGE="http://alx14.free.fr/burncenter/"
+SRC_URI="http://alx14.free.fr/burncenter/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="vorbis"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ virtual/cdrtools
+ media-sound/mpg123
+ vorbis? (
+ >=media-sound/vorbis-tools-1.0_rc2
+ >=media-sound/oggtst-0.0 )"
+
+src_compile() {
+ # Nothing to do.
+ true
+}
+
+src_install() {
+ local modulePath=$(perl -V:installprivlib | perl -p -e "s/^.*?='(.*?)';/\$1/")
+ dobin burncenter
+ dobin bcbatch
+ insinto ${modulePath}
+ doins Burncenter.pm
+
+ dodoc DEVELOP-FRONTENDS README TODO
+}