summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.3.1093-boost-1.76.patch55
-rw-r--r--sci-mathematics/rstudio/rstudio-1.3.1093.ebuild2
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.3.1093-boost-1.76.patch b/sci-mathematics/rstudio/files/rstudio-1.3.1093-boost-1.76.patch
new file mode 100644
index 000000000000..5e832db2883b
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.3.1093-boost-1.76.patch
@@ -0,0 +1,55 @@
+--- rstudio-1.3.1093-orig/src/cpp/r/session/RStdCallbacks.cpp
++++ rstudio-1.3.1093/src/cpp/r/session/RStdCallbacks.cpp
+@@ -19,7 +19,7 @@
+
+ #include <boost/function.hpp>
+ #include <boost/regex.hpp>
+-#include <boost/bind.hpp>
++#include <boost/bind/bind.hpp>
+
+ #include <r/RExec.hpp>
+ #include <r/ROptions.hpp>
+@@ -58,6 +58,7 @@ __declspec(dllimport) SA_TYPE SaveAction
+ }
+
+ using namespace rstudio::core;
++using namespace boost::placeholders;
+
+ namespace rstudio {
+ namespace r {
+--- rstudio-1.3.1093-orig/src/cpp/core/HtmlUtils.cpp.orig
++++ rstudio-1.3.1093/src/cpp/core/HtmlUtils.cpp
+@@ -19,13 +19,15 @@
+
+ #include <boost/format.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+-#include <boost/bind.hpp>
++#include <boost/bind/bind.hpp>
+
+ #include <core/Base64.hpp>
+ #include <core/FileSerializer.hpp>
+ #include <core/RegexUtils.hpp>
+
+ #include <core/http/Util.hpp>
++
++using namespace boost::placeholders;
+
+ namespace rstudio {
+ namespace core {
+--- rstudio-1.3.1093-orig/src/cpp/core/file_lock/FileLock.cpp.orig
++++ rstudio-1.3.1093/src/cpp/core/file_lock/FileLock.cpp
+@@ -26,10 +26,12 @@
+ #include <core/system/Environment.hpp>
+
+ #include <boost/algorithm/string.hpp>
+-#include <boost/bind.hpp>
++#include <boost/bind/bind.hpp>
+
+ // borrowed from SessionConstants.hpp
+ #define kRStudioSessionRoute "RSTUDIO_SESSION_ROUTE"
++
++using namespace boost::placeholders;
+
+ namespace rstudio {
+ namespace core {
+ \ No newline at end of file
diff --git a/sci-mathematics/rstudio/rstudio-1.3.1093.ebuild b/sci-mathematics/rstudio/rstudio-1.3.1093.ebuild
index 4fee0074c081..851ffef54c98 100644
--- a/sci-mathematics/rstudio/rstudio-1.3.1093.ebuild
+++ b/sci-mathematics/rstudio/rstudio-1.3.1093.ebuild
@@ -95,6 +95,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.2.5042-boost-1.73.0.patch
"${FILESDIR}"/${PN}-1.3.1056-R-4.0.0.patch
"${FILESDIR}"/${PN}-1.3.1056-boost-1.74.0.patch
+ "${FILESDIR}"/${PN}-1.3.1093-boost-1.76.patch
)
src_unpack() {
@@ -177,6 +178,7 @@ src_configure() {
-DRSTUDIO_TARGET=$(usex dedicated "Server" "$(usex server "Development" "Desktop")")
-DRSTUDIO_VERIFY_R_VERSION=FALSE
-DRSTUDIO_USE_SYSTEM_BOOST=TRUE
+ -DRSTUDIO_BOOST_SIGNALS_VERSION=2
)
if use !dedicated; then