summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/powerline/files/2.7-ldflags.patch15
-rw-r--r--app-shells/powerline/powerline-2.7-r1.ebuild (renamed from app-shells/powerline/powerline-2.7.ebuild)4
2 files changed, 19 insertions, 0 deletions
diff --git a/app-shells/powerline/files/2.7-ldflags.patch b/app-shells/powerline/files/2.7-ldflags.patch
new file mode 100644
index 000000000000..077c28af2a07
--- /dev/null
+++ b/app-shells/powerline/files/2.7-ldflags.patch
@@ -0,0 +1,15 @@
+diff -Naur powerline-status-2.7/setup.py powerline-status-2.7.new/setup.py
+--- powerline-status-2.7/setup.py 2018-08-12 14:41:44.000000000 -0500
++++ powerline-status-2.7.new/setup.py 2020-06-01 14:56:25.977968288 -0500
+@@ -30,9 +30,10 @@
+ from distutils.ccompiler import new_compiler
+ compiler = new_compiler().compiler
+ cflags = os.environ.get('CFLAGS', str('-O3'))
++ ldflags = os.environ.get('LDFLAGS', str(''))
+ # A normal split would do a split on each space which might be incorrect. The
+ # shlex will not split if a space occurs in an arguments value.
+- subprocess.check_call(compiler + shlex.split(cflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
++ subprocess.check_call(compiler + shlex.split(cflags) + shlex.split(ldflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
+
+ try:
+ compile_client()
diff --git a/app-shells/powerline/powerline-2.7.ebuild b/app-shells/powerline/powerline-2.7-r1.ebuild
index 946e4c10304a..623ac6d9568c 100644
--- a/app-shells/powerline/powerline-2.7.ebuild
+++ b/app-shells/powerline/powerline-2.7-r1.ebuild
@@ -25,3 +25,7 @@ RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/2.7-ldflags.patch
+)