summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/flag-o-matic.eclass2
-rw-r--r--net-libs/ngtcp2/ngtcp2-1.5.0.ebuild2
2 files changed, 3 insertions, 1 deletions
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 0e5271c7824f..ecac452aa0ef 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -139,6 +139,8 @@ _setup-allowed-flags() {
-mno-fxsr -mno-hle -mno-rtm -mno-xsave -mno-xsaveopt
# gcc 4.9
-mno-avx512cd -mno-avx512er -mno-avx512f -mno-avx512pf -mno-sha
+
+ -mevex512 -mno-evex512
)
# Allow some safe individual flags. Should come along with the bug reference.
diff --git a/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild b/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
index 1f15a2e28c49..3d01d4243f5a 100644
--- a/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~x86"
fi
DESCRIPTION="Implementation of the IETF QUIC Protocol"