summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/posh/posh-0.13.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-shells/posh/posh-0.13.1.ebuild b/app-shells/posh/posh-0.13.1.ebuild
index b9d6fe69c69b..cabbfd2573a2 100644
--- a/app-shells/posh/posh-0.13.1.ebuild
+++ b/app-shells/posh/posh-0.13.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
HOMEPAGE="https://salsa.debian.org/clint/posh"
SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
@@ -16,6 +18,12 @@ DEPEND="app-arch/xz-utils"
S=${WORKDIR}/posh
+src_prepare() {
+ default
+ # the tarball apparently contains outdated files
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--exec-prefix="${EPREFIX:-/}"