summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.80.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1701a8351067..90d2455d21e6 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-6.79.1.gh.tar.gz 9377826 BLAKE2B 13bf9383df81bf8aa504e4f1314958c
DIST hypothesis-6.79.2.gh.tar.gz 9377998 BLAKE2B 7b9aa513fa6bf535094ebf9b6aad51df0f9d3a3c0da9e1402a86c8f41b840efe76b97a8204ba746e933128b1586d4622ab784ea3f040b599a7b61c6d563e9f09 SHA512 af8573f99d128300d358362c7f1f7ad801d27a29c89be554bbaa5325ff406d7237b98090ce7ec79fb72b04819f22ce0a3bc27c28028615ac9de8fc4a58d24d27
DIST hypothesis-6.79.3.gh.tar.gz 9378262 BLAKE2B b5feccaa2a3e5af6e0cd688f5b9c78662af9dd044e188f295c922ae6aa7a0bd9e36a461d630c4217f376982e6f47e919b0cb75b8f6bc78056fa8b146b0fc88cb SHA512 6f6b18f6313fcf0d2151ec76d7f97793e181403e8d30c51dd251439f3bc0e204a3b74134017f7e88934eb779a8756f6c541a5ac52041222f1f350f0a7172563e
DIST hypothesis-6.80.0.gh.tar.gz 9376080 BLAKE2B 49aa0e60d520aaf5c76767dfade32d5ebc40c6bc7d6a20937c1134fb0b3904a62778f83e01074060dc1614045d2c4ea559a27fb5ef1634b8adf90a38c359daa7 SHA512 30e0698422d4f1b4c3c592ad86555a7347975ff2ed4d9c50a6672610981dadb2c3c1eae7f42e08075e529b095b13703129c90f22be3f8f40b39482fa8c80118b
+DIST hypothesis-6.80.1.gh.tar.gz 9376526 BLAKE2B edb7012b17f1634745d81de74934424ac6430b9668a9702ce64a6f60b7ca3239c878acf1f958327ff2b1e18b95003733ce36bc6f0ffceb65f1eab69d61ab9b54 SHA512 38962d6428d98861993a7e29627be377b2dee7ef9da5bf06553a1de645e041c5af33f8674c64104e90c1168815ef81ee82bb30e1d66315bc85ba7ad81ab28f20
diff --git a/dev-python/hypothesis/hypothesis-6.80.1.ebuild b/dev-python/hypothesis/hypothesis-6.80.1.ebuild
new file mode 100644
index 000000000000..16dd6b062df8
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.80.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_12 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}