summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/hdf5/files/hdf5-1.14.0-fix-include-path.patch34
-rw-r--r--sci-libs/hdf5/hdf5-1.14.0-r1.ebuild (renamed from sci-libs/hdf5/hdf5-1.14.0.ebuild)1
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.14.0-fix-include-path.patch b/sci-libs/hdf5/files/hdf5-1.14.0-fix-include-path.patch
new file mode 100644
index 000000000000..4530f1fa6d2e
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.14.0-fix-include-path.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/904515
+https://github.com/HDFGroup/hdf5/issues/2422
+https://github.com/HDFGroup/hdf5/issues/2621
+https://github.com/HDFGroup/hdf5/pull/2667
+https://github.com/HDFGroup/hdf5/commit/b77cb393b884c1dbdaffb300aa8c4967d9ba7fb0
+
+From b77cb393b884c1dbdaffb300aa8c4967d9ba7fb0 Mon Sep 17 00:00:00 2001
+From: jhendersonHDF <jhenderson@hdfgroup.org>
+Date: Tue, 11 Apr 2023 14:31:25 -0500
+Subject: [PATCH] Fix improper include of build directory (#2422, #2621)
+ (#2667)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -3012,8 +3012,7 @@ SUBFILING_VFD=no
+ HAVE_MERCURY="no"
+
+ ## Always include subfiling directory so public header files are available
+-CPPFLAGS="$CPPFLAGS -I$ac_abs_confdir/src/H5FDsubfiling"
+-AM_CPPFLAGS="$AM_CPPFLAGS -I$ac_abs_confdir/src/H5FDsubfiling"
++H5_CPPFLAGS="$H5_CPPFLAGS -I$ac_abs_confdir/src/H5FDsubfiling"
+
+ AC_MSG_CHECKING([if the subfiling I/O virtual file driver (VFD) is enabled])
+
+@@ -3061,8 +3060,7 @@ if test "X$SUBFILING_VFD" = "Xyes"; then
+ mercury_dir="$ac_abs_confdir/src/H5FDsubfiling/mercury"
+ mercury_inc="$mercury_dir/src/util"
+
+- CPPFLAGS="$CPPFLAGS -I$mercury_inc"
+- AM_CPPFLAGS="$AM_CPPFLAGS -I$mercury_inc"
++ H5_CPPFLAGS="$H5_CPPFLAGS -I$mercury_inc"
+
+ HAVE_STDATOMIC_H="yes"
+ AC_CHECK_HEADERS([stdatomic.h],,[HAVE_STDATOMIC_H="no"])
diff --git a/sci-libs/hdf5/hdf5-1.14.0.ebuild b/sci-libs/hdf5/hdf5-1.14.0-r1.ebuild
index d69a56ff0f16..8d4d4bf40680 100644
--- a/sci-libs/hdf5/hdf5-1.14.0.ebuild
+++ b/sci-libs/hdf5/hdf5-1.14.0-r1.ebuild
@@ -38,6 +38,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
"${FILESDIR}"/${PN}-1.12.2-no-strip-symbols.patch
+ "${FILESDIR}"/${PN}-1.14.0-fix-include-path.patch
)
pkg_setup() {