summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.95.ebuild80
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.95.ebuild68
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.95.ebuild74
-rw-r--r--dev-python/recommonmark/Manifest2
-rw-r--r--dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild19
-rw-r--r--dev-util/scons/Manifest1
-rw-r--r--dev-util/scons/scons-4.5.1.ebuild (renamed from dev-util/scons/scons-4.5.1-r1.ebuild)18
-rw-r--r--eclass/pypi.eclass35
-rwxr-xr-xeclass/tests/pypi.sh3
-rw-r--r--media-gfx/cairosvg/Manifest1
-rw-r--r--media-gfx/cairosvg/cairosvg-2.7.0.ebuild38
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild62
16 files changed, 381 insertions, 24 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6c5a4753a2b3..a9630ff40193 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.27.84.gh.tar.gz 2378573 BLAKE2B b85d7eeb22b0a2a9264b49a27f2e3d3da
DIST aws-cli-1.27.89.gh.tar.gz 2382599 BLAKE2B 3a2dae3cc1928e149dd605de1e9a350989e1cf4f813dc14466ba40c0a2747e69b6a8c5716d48f2526920798f0d341dcaa7ec0c2fd95af1b5decd3830814a243b SHA512 9a90c933e5ae3f25271ec369607cb6c44adf96dc9d324205714c9790b6744d7f2c8e4c6b901d4bb4f58b6871c315e0543b3f846cf530e7f95ed31d196f8c3326
DIST aws-cli-1.27.93.gh.tar.gz 2385084 BLAKE2B 18dc59339303b9f32e297ca6a37c5d2a9466a2ac2b2f8795baeb686465dfe561ecb5abb29c38d37f32f44408b9ff1e083c330fbe23a5bf3c19a05033993dc533 SHA512 ce979f35966f2c48d8bf74ed95d27e5d6de9e33990bc01556bba660fd5692dd3751002d1dafbba11121e768a21d97130d9e76d309640ade5377193ba79ba1628
DIST aws-cli-1.27.94.gh.tar.gz 2385480 BLAKE2B 8712056c53d704e368f81d38779201d0ef28d0b633ac4a877957b5d6338a6daf45b5408dcf0bee3f6c48a0b10af625bfee835f63e837814b42ec3a57745e4d61 SHA512 48dc09f0af71eb9b9d93ffd2c008511e2379f2a47d4913c6c4296804d3ec3c30a1811564c017388329cac9261b1c3021fadc60771ca9d0952982401f5e4f7c59
+DIST aws-cli-1.27.95.gh.tar.gz 2385780 BLAKE2B 4df38ab1d3d22571dd7d4afa896316b65bf903c61a5644c6d7988d3e841971a85bb7eb449edb0d9c0141e6c768e36ccc19ee155e4a5937050f4876060b3b2df8 SHA512 9b478901a62fbfd45fc23a82b7a8039dbff6e3e5c406153ea435e18b54ec7a263f7e5410cd1a5ac5916906ef9e8f8219f0da46a885ae4f33a43227059e56833f
diff --git a/app-admin/awscli/awscli-1.27.95.ebuild b/app-admin/awscli/awscli-1.27.95.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.95.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index debbc6e2d936..0ee2b4d45ba4 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.84.gh.tar.gz 612921 BLAKE2B cf98272681299aa11454d65a6bf8bc6aa282
DIST boto3-1.26.89.gh.tar.gz 615718 BLAKE2B 3257e6efafaf139daf935385c252c10929be2a4277a8f0f192afc6dbd7cc32fa8f940a4e59ebbe25931c399dedb926a3c1848bd9cc0a7f0d377acb302eabe3b0 SHA512 02ee02b05023e9184f779ab8ff21afa6f7e56f7d2e883d021b2567676c5fc57cad6b475d55316a2017c2a837c41d2f5604824f440060e2f96804c5a61ccdd143
DIST boto3-1.26.93.gh.tar.gz 617542 BLAKE2B 08f045cdac7c977d9a575ca7f487314baf6f358e82b13ff3a2063d85ed23aa98c38445d444ce78730b01381fe04eb5bd5909868a5e01a529d2028c065294714b SHA512 9af0dad9189030bbd310b634af80b731799166d89c561d640308ae913c1f81f0ce50e1a0c303bff974006281be03125e454495936cca30db3cf33a4d95d66783
DIST boto3-1.26.94.gh.tar.gz 617861 BLAKE2B 908b40868735038810cf75c903bbc8bad00a6ea8776b2a5a236683f18f2185971f8a13db5349086b1aef2c4d51361c8ebf30f2d671cea7f4101c9882a59b6acf SHA512 036278668afa33dfdaab9cc2e02c2c3e0596ec1c1b407767f22bc6a4cd87913f883f85430ff6a120c5e0fdd2194b70c911fe7a207bc26ed5fcd415f3754cde35
+DIST boto3-1.26.95.gh.tar.gz 623665 BLAKE2B d1d979210e22d4d39eff7148711be28ceb80b26409567c1d23f67a523667276c3a6b2a79519f89bed6d72c8cd4c8a9e04ad886805de51605c1fefcf45cebd08b SHA512 0147714fc05e5b8cab29ac66d9701fc3f64623f84a800597478133dd20f3637f15471a8cd63fc88820a7229b425843731e00470eb66106cdf525da5ce0ff3091
diff --git a/dev-python/boto3/boto3-1.26.95.ebuild b/dev-python/boto3/boto3-1.26.95.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.95.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 04b1f3a6cb02..0e05afd8969b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.29.84.gh.tar.gz 11220100 BLAKE2B 588efd08ec38eee7e319ea6e1d41af3
DIST botocore-1.29.89.gh.tar.gz 11227280 BLAKE2B 41a1243972e591ea23fb2eebaa5b5fb9547bbd8ccd72fc907c487fd56ebf90d8120ceee472e34a29cd2b036926bc93bda33b564b1b7083e8984daf366eced1f8 SHA512 356298fd3be39957dd60e6268cfd2652998e62950b9060e0774c68e158506dcfea8188059b588c08f520617af38b91eb6b71c16b92f7a71f75f33cb73e7786cf
DIST botocore-1.29.93.gh.tar.gz 11239506 BLAKE2B 7a05d5c611cbeda21e62abbbe13ab18cceae2d8b28136fc8669b09e3ebdcad5e5e352b32e807af7f2f038b6d045f82cf1a9cb3ec854f37db1f3204725fd8971e SHA512 df4ba05c28323321eae25412b97eb9f48978563aad5a0c166515bac3193b0404ebe111565be3b1e42ea47439f749e339ce11cc21736d5403ffbbe689f6fd8da8
DIST botocore-1.29.94.gh.tar.gz 11242930 BLAKE2B d6abdda0ad69bfa635c2cdccefff5c0feaa27fb1a307d5cacb140ded35c246a52ebbe5657a9317bdc1441939d2bd62d5829b2ecce01c05976f56737f92fc3f62 SHA512 23c1fb835d492f414a0a67ac03e50ea31f6343676c7e6e8649067b11e3213f84eb068562fe5bd9a49ead9e37381ab132ac820d98fa4af805b41eaf53b0f9cb1b
+DIST botocore-1.29.95.gh.tar.gz 11252473 BLAKE2B 500dfc60af5127b56d41fc8ffa2742b5a0086614e48517590c795ae51ea55936a621e4a88d27248a9c52dfb4fe99c716ac2b191329071b94c13078facf4b0967 SHA512 2efbff00cc696930bb71713ce18ad61449c2e79c0ede48218347e3c410a9ff9752c44a35dd03f45286c2f6e05b34e85bd8b01c0c9f92d877c9e2d0209b6cafe6
diff --git a/dev-python/botocore/botocore-1.29.95.ebuild b/dev-python/botocore/botocore-1.29.95.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.95.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/recommonmark/Manifest b/dev-python/recommonmark/Manifest
index 83874646d3ec..27dca1e32fbe 100644
--- a/dev-python/recommonmark/Manifest
+++ b/dev-python/recommonmark/Manifest
@@ -1 +1 @@
-DIST recommonmark-0.7.1.tar.gz 24720 BLAKE2B 6543a23bd262be0ff6847fc1eb1bd3dad433606aa1adb52162cab2e0c4dd2265ac41b3816bbe1994c4f6ca732105712dbc9cd295d5cfd93061ad83520b8f449c SHA512 3e03440d606ea6247df9bd122a6fa2dccf01c0c315eeace046d5cd336657e26bbd1c6b7ad4ba46f344215905128b72508c036cc57bbe4b5e27df50c55371fe01
+DIST recommonmark-0.7.1.gh.tar.gz 24720 BLAKE2B 6543a23bd262be0ff6847fc1eb1bd3dad433606aa1adb52162cab2e0c4dd2265ac41b3816bbe1994c4f6ca732105712dbc9cd295d5cfd93061ad83520b8f449c SHA512 3e03440d606ea6247df9bd122a6fa2dccf01c0c315eeace046d5cd336657e26bbd1c6b7ad4ba46f344215905128b72508c036cc57bbe4b5e27df50c55371fe01
diff --git a/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild b/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
index 9761a3e670ef..73dd01dd89d1 100644
--- a/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
+++ b/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
@@ -8,8 +8,15 @@ PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Python docutils-compatibility bridge to CommonMark"
-HOMEPAGE="https://recommonmark.readthedocs.io/"
-SRC_URI="https://github.com/rtfd/recommonmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://recommonmark.readthedocs.io/
+ https://github.com/readthedocs/recommonmark/
+ https://pypi.org/project/recommonmark/
+"
+SRC_URI="
+ https://github.com/readthedocs/recommonmark/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -26,4 +33,12 @@ PATCHES=(
"${FILESDIR}/${PN}-0.6.0-sphinx3-2.patch"
)
+# These tests are sensitive to Sphinx formatting changes and they will never
+# get fixed because upstream has archived the project in favor of myst_parser.
+# Bug #866009
+EPYTEST_DESELECT=(
+ "tests/test_sphinx.py::GenericTests::test_headings"
+ "tests/test_sphinx.py::CustomExtensionTests::test_integration"
+)
+
distutils_enable_tests pytest
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index e5ddc6240844..b4cb22f2c203 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -3,7 +3,6 @@ DIST SCons-4.5.1.tar.gz 3194371 BLAKE2B 830e3365be99e38aec0f3b99d406bb7547d3d8b7
DIST scons-4.4.0-user.html 1608381 BLAKE2B ff4eb1e0f9c5e8ea7ca44cc00dc37e3e2dd38c24cb09a857c691e6a48f11e5fc86a55740037cc295e6b23df2a1c1b600adf0462320ec87cc26d4bcf919b07342 SHA512 8c1d6578270054efba34c56ddc07b4314bf62630f6a445f5b9f865cc48d593f6c92101a8d216dece201b8d6cb5bce59ff4adb51caaa40128e96b6235087f748c
DIST scons-4.4.0-user.pdf 2964111 BLAKE2B 45b37c99c3f3d0e9969a16506e27aeabfd562155405f5a59ba79c24404b14e5588fbd0673d86e2266adbd25eca140c9e1cf86e271228658591c0d9285474f078 SHA512 57330f685e7c775cb1c782e40f711c2b2322fad19212a22a920aff92db974610cc78f276e1606fb827660bb488ce803e2458bb9d93c452fa0600df4478f03d06
DIST scons-4.4.0.gh.tar.gz 5808265 BLAKE2B f6ce757f2edc40551b05285098626bb62def6abda2380d4885ee4443868e715e53aaa34f26c09dc689bb6ade26d1b0e276046fe3b1d2ddf8eb40400bca9ea164 SHA512 01fcd40bf818ca22a278973af1cda3024efb74cf877f15d46607fda860448fbd577fc96ba33fef2bed3d145e662a0371f55e8c927e7ac44feea7f3081791ce11
-DIST scons-4.5.1-mergeflags.patch 10518 BLAKE2B ea059c4347cfa8dcd99353c1f6b6c1d3aae1c6225b4683e421f3f3ea9181d5597862603c2491abff40dd1599094638239f34bf88458e7c44a8f28908eb91934c SHA512 11771c99d64cee413311f595faec8d2025152a7871ef53bdf0b22be45ffefc0d0c4bf49d185a10c1d3d2fb76ac94b04d992990375dc144587b101761a5d985a4
DIST scons-4.5.1-user.html 1655168 BLAKE2B 644c808f129d2d83f40b1ef2c8c12781b697a0120dfc00f5f0425e88e23c609290ecf2c8b6daad556c876ae3a86e8b262c53915b05d69c6e3c79f58395789362 SHA512 171d9330df520a75fbc124bf646c55c5868b24343ff46755a6283fe444ad4e090f5658dafa7239e708b4ff8b910e81201c27655674bdaffd20e8cc6ffb81d633
DIST scons-4.5.1-user.pdf 3023817 BLAKE2B caa782f77fac668eee0ccd76f3e96168ae3d61c9c3e80123c34bc45625182f77973fbab24170c5f67f133c6124412eadbf02c3497373211560c58a348d6b00ab SHA512 41fddff58032b6364ff3935259d4bf81a0d69398cd52158c42be71e4ff6efaebd2faaf1354781f7336ba1aa4f0cf99f0f37edcd72baf325f9ced7ec88b76ce88
DIST scons-4.5.1.gh.tar.gz 5844118 BLAKE2B 88a82e12a034f6d0748555d0d33716e5af6ff957a9345d5b0ba87c2a36544bae0965ea0a29e3cc80d6d2493f3f8bf0bd314bed5824dc609123972f640b19a53a SHA512 160089342b93197237b9f0c5f0ada42126f3e5c83e0026f6dc121aaae85c94774b01ea3b0b0fc56edf3effd87d91612b2167d004abe7a00bd8d107d5415f5d4a
diff --git a/dev-util/scons/scons-4.5.1-r1.ebuild b/dev-util/scons/scons-4.5.1.ebuild
index d12cdf7c1bd8..87c03687ce2a 100644
--- a/dev-util/scons/scons-4.5.1-r1.ebuild
+++ b/dev-util/scons/scons-4.5.1.ebuild
@@ -18,16 +18,16 @@ HOMEPAGE="
"
SRC_URI="
https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${MY_P}.tar.gz
- https://github.com/SCons/scons/pull/4322.patch
- -> ${P}-mergeflags.patch
- https://github.com/SCons/scons/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
doc? (
https://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf
-> ${P}-user.pdf
https://www.scons.org/doc/${PV}/HTML/${PN}-user.html
-> ${P}-user.html
)
+ test? (
+ https://github.com/SCons/scons/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ )
"
S="${WORKDIR}/${P}/src"
@@ -45,9 +45,6 @@ BDEPEND="
"
PATCHES=(
- # https://bugs.gentoo.org/900971
- "${DISTDIR}/${P}-mergeflags.patch"
-
# support env passthrough for Gentoo ebuilds
"${FILESDIR}"/scons-4.1.0-env-passthrough.patch
# respect CC, CXX, C*FLAGS, LDFLAGS by default
@@ -57,7 +54,12 @@ PATCHES=(
src_unpack() {
# use the git directory structure, but put pregenerated release
# inside src/ subdirectory to make our life easier
- unpack "${P}.gh.tar.gz"
+ if use test; then
+ unpack "${P}.gh.tar.gz"
+ else
+ mkdir -p "${P}"/src || die
+ fi
+
tar -C "${P}"/src --strip-components=1 -xzf "${DISTDIR}/${MY_P}.tar.gz" || die
}
diff --git a/eclass/pypi.eclass b/eclass/pypi.eclass
index 79007a2ad0ed..ca3b6f67803d 100644
--- a/eclass/pypi.eclass
+++ b/eclass/pypi.eclass
@@ -50,6 +50,19 @@ _PYPI_ECLASS=1
# When set to a non-empty value, disables project name normalization
# for the default SRC_URI and S values.
+# @ECLASS_VARIABLE: PYPI_PN
+# @PRE_INHERIT
+# @DESCRIPTION:
+# The PyPI project name. This should be overriden scarcely, generally
+# when upstream project name does not conform to Gentoo naming rules,
+# e.g. when it contains dots or uppercase letters.
+#
+# Example use:
+# @CODE
+# PYPI_PN=${PN/-/.}
+# @CODE
+: ${PYPI_PN:=${PN}}
+
# @FUNCTION: pypi_normalize_name
# @USAGE: <name>
# @DESCRIPTION:
@@ -99,9 +112,9 @@ pypi_translate_version() {
# generated using build systems that did not follow PEP 625
# (i.e. the sdist name contains uppercase letters, hyphens or dots).
#
-# If <package> is unspecified, it defaults to ${PN}. The package name
-# is normalized according to the specification unless `--no-normalize`
-# is passed.
+# If <package> is unspecified, it defaults to ${PYPI_PN}. The package
+# name is normalized according to the specification unless
+# `--no-normalize` is passed.
#
# If <version> is unspecified, it defaults to ${PV} translated
# via pypi_translate_version. If it is specified, then it is used
@@ -121,7 +134,7 @@ pypi_sdist_url() {
die "Usage: ${FUNCNAME} [--no-normalize] <project> [<version> [<suffix>]]"
fi
- local project=${1-"${PN}"}
+ local project=${1-"${PYPI_PN}"}
local version=${2-"$(pypi_translate_version "${PV}")"}
local suffix=${3-.tar.gz}
local fn_project=${project}
@@ -135,8 +148,8 @@ pypi_sdist_url() {
# @DESCRIPTION:
# Output the wheel filename for the specified project/version tuple.
#
-# If <package> is unspecified, it defaults to ${PN}. The package name
-# is normalized according to the wheel specification.
+# If <package> is unspecified, it defaults to ${PYPI_PN}. The package
+# name is normalized according to the wheel specification.
#
# If <version> is unspecified, it defaults to ${PV} translated
# via pypi_translate_version. If it is specified, then it is used
@@ -154,7 +167,7 @@ pypi_wheel_name() {
die "Usage: ${FUNCNAME} <project> [<version> [<python-tag> [<abi-platform-tag>]]]"
fi
- local project=$(pypi_normalize_name "${1-"${PN}"}")
+ local project=$(pypi_normalize_name "${1-"${PYPI_PN}"}")
local version=${2-"$(pypi_translate_version "${PV}")"}
local pytag=${3-py3}
local abitag=${4-none-any}
@@ -172,7 +185,7 @@ pypi_wheel_name() {
# the wheel contents will be unpacked straight into ${WORKDIR}.
# You need to add a BDEPEND on app-arch/unzip.
#
-# If <package> is unspecified, it defaults to ${PN}.
+# If <package> is unspecified, it defaults to ${PYPI_PN}.
#
# If <version> is unspecified, it defaults to ${PV} translated
# via pypi_translate_version. If it is specified, then it is used
@@ -197,7 +210,7 @@ pypi_wheel_url() {
fi
local filename=$(pypi_wheel_name "${@}")
- local project=${1-"${PN}"}
+ local project=${1-"${PYPI_PN}"}
local version=${2-"$(pypi_translate_version "${PV}")"}
local pytag=${3-py3}
printf "https://files.pythonhosted.org/packages/%s" \
@@ -210,10 +223,10 @@ pypi_wheel_url() {
if [[ ${PYPI_NO_NORMALIZE} ]]; then
SRC_URI="$(pypi_sdist_url --no-normalize)"
- S="${WORKDIR}/${PN}-$(pypi_translate_version "${PV}")"
+ S="${WORKDIR}/${PYPI_PN}-$(pypi_translate_version "${PV}")"
else
SRC_URI="$(pypi_sdist_url)"
- S="${WORKDIR}/$(pypi_normalize_name "${PN}")-$(pypi_translate_version "${PV}")"
+ S="${WORKDIR}/$(pypi_normalize_name "${PYPI_PN}")-$(pypi_translate_version "${PV}")"
fi
fi
diff --git a/eclass/tests/pypi.sh b/eclass/tests/pypi.sh
index ebfcdb630856..471ac048b18a 100755
--- a/eclass/tests/pypi.sh
+++ b/eclass/tests/pypi.sh
@@ -5,7 +5,8 @@
EAPI=8
source tests-common.sh || exit
-PN=Foo.Bar
+PN=foo-bar
+PYPI_PN=Foo.Bar
PV=1.2.3_beta2
WORKDIR='<WORKDIR>'
diff --git a/media-gfx/cairosvg/Manifest b/media-gfx/cairosvg/Manifest
index db1a46b0a071..4317383778f8 100644
--- a/media-gfx/cairosvg/Manifest
+++ b/media-gfx/cairosvg/Manifest
@@ -1 +1,2 @@
DIST CairoSVG-2.6.0.tar.gz 8398114 BLAKE2B d4aca284fe3756c40c62dfb2b29e4670c947df13dd76e5104a13cb963bbdf6aa1f7fd242748d6fd0ca524aa03578c3449fa8ea6d86b9a8ce4a64976c32e96627 SHA512 dc504233a8f3fccfc8d4082328bfc0f06a4ebe0249801f764b9aed6b3bad5f953786352930ab199b10b301d0f44a8c2ef2e79eeea198c9094e697fdaa4db48d5
+DIST CairoSVG-2.7.0.tar.gz 8398722 BLAKE2B 00a82ec395480aba7bf1c1e2025f53ad5e3bb6336110e709f9cdb67c8a2eeafb071da0dc44aabceadd4c8c274f4560d264c101f43c89c6faa96ea47018a67f62 SHA512 7775654f55ac436c91e781a91ca9ca89826068638fdbf65b9717899dfd5d974dacc7cf2e7ee24fad1be8ded899e1c1f441137f25c2a8185b67e7ecc84c2c9c50
diff --git a/media-gfx/cairosvg/cairosvg-2.7.0.ebuild b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
new file mode 100644
index 000000000000..eca08d075044
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="CairoSVG"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="
+ https://cairosvg.org/
+ https://github.com/Kozea/CairoSVG/
+ https://pypi.org/project/CairoSVG/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # this test compares output against old version; this makes little
+ # sense for us and requires both distfiles around
+ test_non_regression
+)
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 9f79dd005ee7..f881777ad221 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-clipman-plugin-1.6.2.tar.bz2 465656 BLAKE2B bde94cda7ec97d0af9f238bb3cffb69a7f469a03d27608681042ad701175a1900abed1d79bdc38d45afe5ed48da2054a837358bd150f5075bc194a9547bbf56f SHA512 4bd49b3b6311d232d422d92007638b05409bc0c90fdc20a394590000ac8c706c0502b99a3c89a0276ca1c0e2cfb0a151c78a0a8b18a16bbf65cc5778bcb51db2
+DIST xfce4-clipman-plugin-1.6.3.tar.bz2 486276 BLAKE2B f92c93e4ab57fbe37560c389620696f5c11fa8cbd328f29d4895c25c6f18fec88267cc152a1cab39084f08f8fdc070669b665cbad4089ae9577be776a3ad3663 SHA512 a117f64035a6656c2f8603d9b0adec18bcbe8e1ee6a80b838e4cc40480cc3510afe5f32815ff89b1936cbdbadadf8e1e645f0202d97cc877aec125b51b72064b
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild
new file mode 100644
index 000000000000..955d7912e0b2
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+DEPEND="
+ >=dev-libs/glib-2.60:2=
+ >=x11-libs/gtk+-3.22.29:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}