summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/string-theory/string-theory-3.3.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/dev-cpp/string-theory/string-theory-3.3.ebuild b/dev-cpp/string-theory/string-theory-3.3.ebuild
index a8bb093a351a..82fb3efef9de 100644
--- a/dev-cpp/string-theory/string-theory-3.3.ebuild
+++ b/dev-cpp/string-theory/string-theory-3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,3 +13,18 @@ S="${WORKDIR}/string_theory-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}