summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hidapi/Manifest1
-rw-r--r--dev-python/hidapi/hidapi-0.14.0_p4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
index b8b285bf45c4..6a0b02e93192 100644
--- a/dev-python/hidapi/Manifest
+++ b/dev-python/hidapi/Manifest
@@ -1 +1,2 @@
DIST hidapi-0.14.0.post3.tar.gz 172567 BLAKE2B 6bd08502bf8524e4050ef4cd113703b8cde8b414cbaace959f26189345521e06ef8bb2c0492a5582db97be25dca0e1ca2d93369aaa2db149b4f94cb4a990c426 SHA512 5e3a3c15fd58d9afc4b40d06c82e0aebf40a083e4331c68ee809ae26ee08710507e85f1e95311210ce4c0ba04e7f15cabd40a0a72b74b2b8000fabdf93e2883f
+DIST hidapi-0.14.0.post4.tar.gz 174388 BLAKE2B 94032019f19d1d7f67a6fb2bde518694de5b3a3c94fad1e5dd090dbd98d630fba94a55ef55b1f28591f13eada6ce023b3b11648f0d7ec3e79e4e94cac4f05a3d SHA512 16e567a7390c3a7abd4e271ced41a4e01041d03c4e14168db92a62afa39e8992b078577c1b836b6728e683ac5a9621553bedf426fe15aa8ca3ccae06ce55d79d
diff --git a/dev-python/hidapi/hidapi-0.14.0_p4.ebuild b/dev-python/hidapi/hidapi-0.14.0_p4.ebuild
new file mode 100644
index 000000000000..5b71e5edf404
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.14.0_p4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Cython interface to HIDAPI library"
+HOMEPAGE="
+ https://github.com/trezor/cython-hidapi/
+ https://pypi.org/project/hidapi/
+"
+
+LICENSE="|| ( BSD GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/hidapi-$(ver_cut 1-3)
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ --with-system-hidapi
+ )
+}
+
+python_test() {
+ epytest tests.py
+}