summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyaudio/Manifest1
-rw-r--r--dev-python/pyaudio/files/pyaudio-0.2.11-python310-size_t.patch28
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild42
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/pyaudio/Manifest b/dev-python/pyaudio/Manifest
index 371ba5e2f34c..cff08f22e576 100644
--- a/dev-python/pyaudio/Manifest
+++ b/dev-python/pyaudio/Manifest
@@ -1,2 +1 @@
-DIST PyAudio-0.2.11.tar.gz 37428 BLAKE2B 18db51a651876135a6afc6c8c60e2221017a311fe1aec10497905bc35b81a73b5e9f27201431566bac3d13bcf582ec12a3b818c51f0e5e70aeb4ad177608461a SHA512 64db5542ee60837c9b07677e146fc7b060ff47c8b1c04cbb575bce79dd3ed4776c201e169ff2860f27dbe9e00a77046ba0cb925b55f7c546f8de46c6df68954e
DIST PyAudio-0.2.13.tar.gz 46820 BLAKE2B f0c55f4d6d028ab1210c031b6a3808f93f7963a49cf54e4c9ae65bf936f218386d4a43322b9bd645233e6f881e3d15cdcc6ceeb7fe65fd287696048b206cbfbf SHA512 1ae453cae442118ae1b0db44ca8736621a361af3686e47561bffa0d43352039ed5f882412ca22a2a4320b362f966e727b0e38bb9706e99b85d99bc16cc943008
diff --git a/dev-python/pyaudio/files/pyaudio-0.2.11-python310-size_t.patch b/dev-python/pyaudio/files/pyaudio-0.2.11-python310-size_t.patch
deleted file mode 100644
index 445a9b7e9c44..000000000000
--- a/dev-python/pyaudio/files/pyaudio-0.2.11-python310-size_t.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://git.skeh.site/skeh/pyaudio/commit/2ee560056ec889ea7cd3ce1801b796b0939dd540
-https://bugs.gentoo.org/855626
-
-From 2ee560056ec889ea7cd3ce1801b796b0939dd540 Mon Sep 17 00:00:00 2001
-From: Derek Schmidt <skeh@is.nota.live>
-Date: Tue, 14 Dec 2021 21:46:11 -0700
-Subject: [PATCH] Use Py_ssize_t for tuple return on stream methods
-
---- a/src/_portaudiomodule.c
-+++ b/src/_portaudiomodule.c
-@@ -25,6 +25,7 @@
- */
-
- #include <stdio.h>
-+#define PY_SSIZE_T_CLEAN
- #include "Python.h"
- #include "portaudio.h"
- #include "_portaudiomodule.h"
-@@ -1291,7 +1292,7 @@ int _stream_callback_cfunction(const void *input, void *output,
- PyObject *py_status_flags = PyLong_FromUnsignedLong(statusFlags);
- PyObject *py_input_data = Py_None;
- const char *pData;
-- unsigned output_len;
-+ Py_ssize_t output_len;
- PyObject *py_result;
-
- if (input) {
-
diff --git a/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild b/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild
deleted file mode 100644
index b15c9e01e824..000000000000
--- a/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-MY_PN="PyAudio"
-
-DESCRIPTION="Python bindings for PortAudio"
-HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
-RESTRICT="test"
-
-RDEPEND="media-libs/portaudio"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx sphinx
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2.11-python310-size_t.patch
-)
-
-python_test() {
- elog "These tests require an OS loopback sound device that forwards audio"
- elog "output, generated by PyAudio for playback, and forwards it to an input"
- elog "device, which PyAudio can record and verify against a test signal."
-
- cd tests || die
- # pyaudio_tests have very complicated runtime requirements, therefore skipping them.
- "${EPYTHON}" -m unittest error_tests -v || die "Tests fail with ${EPYTHON}"
-}