summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/flowgrind/Manifest1
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.8.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/Manifest b/net-analyzer/flowgrind/Manifest
index 60af6addd626..92a9c6c986f8 100644
--- a/net-analyzer/flowgrind/Manifest
+++ b/net-analyzer/flowgrind/Manifest
@@ -1 +1,2 @@
DIST flowgrind-0.8.0.tar.bz2 298730 BLAKE2B e924c9900d24565dc025af47d57173d828eea6a0d0bce462ab1e9cb38a14b1ac14b4148797c164212473852f5c0525161766b115b5a435fbfd673dbde8e14765 SHA512 2af250da696c4d0f613191e7a2e3084b2aa1dc995665a4164324cdb2cc56af7b000b8a2f5d5e7ac8ebbad3ae0ba4fc8eb641afe65c1a842a633c19e95ba3e65a
+DIST flowgrind-0.8.2.tar.bz2 264486 BLAKE2B f0135abad43066895ce9acfb0050d12a22054d03f59e48164cde0444b3677a7581e86f25a5a967279432c95a65811135a5ce28da0f041553bca6299aabd783fa SHA512 6d1395881f45fb04b2c73bc7e01cea6610795b58f59c297577c8f30942c81334e8e95cefb2331e5e40dc5f4df64a21307a94d471113251fd3127272cd081bb7b
diff --git a/net-analyzer/flowgrind/flowgrind-0.8.2.ebuild b/net-analyzer/flowgrind/flowgrind-0.8.2.ebuild
new file mode 100644
index 000000000000..6560928a5f0d
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gsl pcap"
+
+RDEPEND="dev-libs/xmlrpc-c:=[abyss,curl]
+ sys-apps/util-linux
+ gsl? ( sci-libs/gsl:= )
+ pcap? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc doxygen) \
+ $(use_with gsl) \
+ $(use_with pcap)
+}
+
+src_compile() {
+ default
+
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html
+}