summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/genlop/files/genlop-0.30.10-sandbox.patch29
-rw-r--r--app-portage/genlop/genlop-0.30.10-r2.ebuild33
2 files changed, 62 insertions, 0 deletions
diff --git a/app-portage/genlop/files/genlop-0.30.10-sandbox.patch b/app-portage/genlop/files/genlop-0.30.10-sandbox.patch
new file mode 100644
index 000000000000..1b4efdb97687
--- /dev/null
+++ b/app-portage/genlop/files/genlop-0.30.10-sandbox.patch
@@ -0,0 +1,29 @@
+From af0fccf158a0a5d0c300be2eae167eace93cc1d3 Mon Sep 17 00:00:00 2001
+From: Joe Breuer <gentoo@jmbreuer.net>
+Date: Sat, 11 May 2019 21:08:21 -0700
+Subject: [PATCH] genlop -c: filter pid-ns-init duplicates (bug 677890)
+
+The latest stable version of portage introduces a pid-ns-init
+process which must be filtered in order to avoid duplicates.
+
+Bug: https://bugs.gentoo.org/677890
+Signed-off-by: Zac Medico <zmedico@gentoo.org>
+---
+ genlop | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/genlop b/genlop
+index b28c9d6..c154aa4 100755
+--- a/genlop
++++ b/genlop
+@@ -706,7 +706,7 @@ sub current()
+ # not check for sanity and have users check their FEATURES instead.
+ my @targets = ();
+ my @sandbox_pids = ();
+- my @sandbox_procs = qx{ps ax -o pid,args | tail -n +2 | sed -e's/^ *//' | grep ' sandbox ' | grep -v ' grep '};
++ my @sandbox_procs = qx{ps ax -o pid,args | tail -n +2 | sed -e's/^ *//' | grep ' sandbox ' | grep -v -e ' grep ' -e 'pid-ns-init '};
+ my ($e_curmerge, $e_lastmerge);
+ foreach (@sandbox_procs)
+ {
+--
+2.21.0
diff --git a/app-portage/genlop/genlop-0.30.10-r2.ebuild b/app-portage/genlop/genlop-0.30.10-r2.ebuild
new file mode 100644
index 000000000000..36cc50c5a1cc
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.10-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl"
+SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/Date-Manip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+# Populate the patches array for any patches for -rX releases
+PATCHES=(
+ "${FILESDIR}"/${P}-sync.patch
+ "${FILESDIR}"/${P}-sandbox.patch
+)
+
+src_install() {
+ dobin genlop
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}