summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-2.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 7d79f97fbc35..5c202136b6e0 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -2,3 +2,4 @@ DIST jsonpickle-1.4.2.tar.gz 104745 BLAKE2B af12141c867cd3dbecace5b7bc637b554c51
DIST jsonpickle-1.5.0.tar.gz 106088 BLAKE2B dcd35979a428180f10611638c831b083d9b8307729a0b19fe89b283c30ecac58477bd6a66e89c31e214dd2f100385d9933dc00d506e1f9bbb4b6ea9c3a0eaed3 SHA512 7828ded98173cb10908a9d60fa6b3f358add360d738cd85a90f012ca24b15c6bbb19c611027bdb0a4d25fe0649978ae59ff08fb7b717ef503a9916152aa6f849
DIST jsonpickle-1.5.1.tar.gz 109560 BLAKE2B 07dd2a469f0bf6fe531d34b5f2d731c6aca863899ce804f44c14b38f93b8c8213b1bf4fc4cc19dc26dcb40d71bfded1115060e54570742afd393bd0d63f12d2d SHA512 ee3694e961bfbb6cc985691fb4821cf831dd6a2cbbdc8c6d1ba8e43fe7a4bba3d4b6868a02f76b88d9b036cebf51b217171504a6647f26b0e2d11727baee62f3
DIST jsonpickle-1.5.2.tar.gz 110239 BLAKE2B 3d4ee457a3f45dd1a6d1004d3fce66c95057958ec172227a7590631e479bd3a63dafe2ece04f5a0a78b9e283f61d949f5c359e4dd9270e162a3060e1032fc562 SHA512 609effeb5553c7c273aa621a8e86b4e630754eab1a948c505a08c98ff13e7f2622a0eb71374c03b69cf8e07c9a3b06fc9d282efba299a720b342424d642cfc6e
+DIST jsonpickle-2.0.0.tar.gz 110336 BLAKE2B 574dab58418c5225a9364836d04eaabf3384e9dab404d191846a4bb41e9c8bbb51243a6a231ec8baf05ff9be337e12b5c96c46b74a327e9f05653ca81bf6ccf2 SHA512 acba11e5dfce116b27edfe0fdccdd74755e299aa43f873dd1ce547d947b58f14c1059c21d04007b5be0857f7ce69fe5355fb2edc47a99cc2217fe00297ca78d3
diff --git a/dev-python/jsonpickle/jsonpickle-2.0.0.ebuild b/dev-python/jsonpickle/jsonpickle-2.0.0.ebuild
new file mode 100644
index 000000000000..cfb3bc401537
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl.
+RDEPEND="
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)
+"
+# toml via setuptools_scm[toml]
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx "docs/source"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # too many dependencies
+ rm tests/pandas_test.py || die
+ # broken with gmpy
+ rm tests/ecdsa_test.py || die
+
+ sed -i -e 's:--flake8 --black --cov::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv tests || die "Tests failed with ${EPYTHON}"
+}