summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
index eb46a256ccff..84bd5353b4fb 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
@@ -14,7 +14,15 @@ EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}