summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.66.0.ebuild121
2 files changed, 124 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 0ead5a8ae531..0ec5f4d8fe21 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -7,3 +7,6 @@ DIST vscodium-1.64.2-arm64.tar.gz 111168123 BLAKE2B 015163f9129e95cce5cb4df255cf
DIST vscodium-1.65.2-amd64.tar.gz 110791055 BLAKE2B c6685f78c786dd36ddb79adce5485670016dc5bf8e72550a0d6f39425237dbdf75c36612e053f74db0c7e92cbc7f21dcd641a1573e03741eed8ae7573d7e6608 SHA512 5a79be254d8fd21e22ca1b557bf11138948793518e761f20cfcc9a8a142e5ae14845989e4a2341f4594a03df0ab9b03e4df971123136c636e1b56bb310397f2c
DIST vscodium-1.65.2-arm.tar.gz 93766888 BLAKE2B 23f1b4a5839b4d8ce35779ae7cd033cfa5ced68272fcb9783307d000ee58dd145d68e8f84e963a1a0dc33ccca81b47119f95cbe49ee788eac5921c9b6ad9071e SHA512 bfc20b5d3de19afb02c11c6dce5b06dec9d843ed7989e400a2d0d2a7f98289db2ae5e7c6262fd31b353eee4efb4f6455aeedffa44e0e7162be03d688ef42c0cb
DIST vscodium-1.65.2-arm64.tar.gz 108364942 BLAKE2B 05fe48a28f9d97487190725e52ef719db7487e27ec537be185bcb8e4ab56137047261b1221b3cf3909ab07fd95e50135a29a57c802e51c35511718c1822fd49a SHA512 42a2bde4685aecff7b15e8315ef5edf05150e9f1228cd55a62693dc5a03ed5154e01353367c29357d652c82c561477b9d6bad34c0aacf7638b3e4597c31312cc
+DIST vscodium-1.66.0-amd64.tar.gz 115792381 BLAKE2B fca762114695e2cebc3658dee0f6e7d7b556d60278a4da512e51f6f3b5bb17b81f83f4a01c2b950c2439e21083023f6e985368419a55b83d0ebe8ab5e303c6cd SHA512 ec4c0bc9a9d928ea2991f5ec9cae247f692601d4e1e63c8b47dcc6d2f62c8e42ef0ebeb800b2cf3864ec66d486e4e17cbd7fb517c2f10727b4203bbb968da305
+DIST vscodium-1.66.0-arm.tar.gz 97612567 BLAKE2B c41b46469cc96f3609982fe1334f8c6e2801a8cac59cd9e30f0c523fdada42b7de711dfbc3ab77e08c136e13088f647010b44404d81152bc38bda130a8d41101 SHA512 dc2820c3fb59be9a5b2152fd45ec7c1617eb7cfc6272d7bed111b5c8d1aa6902e7f59a71df965bb0ff97e9f95d6e59e6ec3db5c55b7185424cffea1d8aa40e26
+DIST vscodium-1.66.0-arm64.tar.gz 113504867 BLAKE2B 2076d239950c745abc4ebf723f832a9934d31ae9582d7a9d1d51a378a79a05b83c0e5bd62a750e63174927d57097d113861633caea80fe2e70559fd8a5965a69 SHA512 46d789aa41991813a758dcf30764353292d6305431407c85249a039681264a7dbe9741569770aa14e2bd8cd9086e146cf128fca382abd383bcfd522f4c332537
diff --git a/app-editors/vscodium/vscodium-1.66.0.ebuild b/app-editors/vscodium/vscodium-1.66.0.ebuild
new file mode 100644
index 000000000000..906a2b847f99
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.66.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/askpass.sh
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/askpass-empty.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+
+ if has_version -r ">=gui-libs/wlroots-0.15"; then
+ elog
+ elog "The wayland backend of vscodium crashes with >=gui-libs/wlroots-0.15"
+ elog "This will be fixed upstream in a later release"
+ elog "Please run the xwayland version for now, on wlroots based DEs."
+ elog "For more information, see https://bugs.gentoo.org/834082"
+ fi
+}