summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.56.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index 0e9f4fc57ba6..82e9164a7a2a 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,3 +1,2 @@
-DIST glibmm-2.56.0.tar.xz 6859520 BLAKE2B 8d7f0120de211002d587e6ec0d3750dcdce60abae6506395b318be876d5ed680b1451920063f06d6d9655137d50482a9ba936caa0f6da127bb3855e43b4d877f SHA512 65e577009019e30e340ae5fe6e4c854e5a75551b2eb83ad85403d73eb4e77879783162d4c3c354bc37be0be842f0ddffc1977021a5e0c32985fb596d86929c08
DIST glibmm-2.56.1.tar.xz 6841240 BLAKE2B db0e1402f322fd31138cf4db2fc2fabb6fb9896f226f98bd524fe005f0e3412f6973774571b7ec79a9e3c79f6622b0969a55dc91631cc996906dd1e558ad4fe8 SHA512 fd5ad19c5dcba484573520e1d00b5bbb600ee805ab8cd9c0d985880cc1bcbe67ad31fa9f2b5789b5892eddd6be345e3f308593e5ef021e1cfda132e4235fb735
DIST glibmm-2.58.1.tar.xz 6778632 BLAKE2B e51e43cb9361147627c2ffc4c232bd8b15d935cc3a20a4fa8d98f5be9c45f7dd635aab69177d033cf65a6e39cee53bcc723be56cc8db966e88b00b5f9cb1f29a SHA512 c1a67412e6de3853557318cd921e6e73874a14ffd3cb51fc158b0d45fb1d5c2560e011b3b0be7f8cf8afee13952e824625d832e5237288b974c2ba20a6f042cb
diff --git a/dev-cpp/glibmm/glibmm-2.56.0.ebuild b/dev-cpp/glibmm/glibmm-2.56.0.ebuild
deleted file mode 100644
index 20a072129508..000000000000
--- a/dev-cpp/glibmm/glibmm-2.56.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2 multilib-minimal
-
-DESCRIPTION="C++ interface for glib2"
-HOMEPAGE="https://www.gtkmm.org"
-
-LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc debug test"
-
-RDEPEND="
- >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.55.1:2[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-# dev-cpp/mm-common needed for eautoreconf
-
-src_prepare() {
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 1 failed"
- fi
-
- # don't build examples - we want to install example sources, not binaries
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 2 failed"
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" gnome2_src_configure \
- $(use_enable debug debug-refcounting) \
- $(multilib_native_use_enable doc documentation) \
- --enable-deprecated-api
-}
-
-multilib_src_test() {
- cd tests
- default
-
- for i in */test; do
- ${i} || die "Running tests failed at ${i}"
- done
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
- find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
- dodoc -r examples
-}