summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/doctest-ignore-unicode/doctest-ignore-unicode-0.1.2-r1.ebuild18
-rw-r--r--eclass/distutils-r1.eclass2
2 files changed, 19 insertions, 1 deletions
diff --git a/dev-python/doctest-ignore-unicode/doctest-ignore-unicode-0.1.2-r1.ebuild b/dev-python/doctest-ignore-unicode/doctest-ignore-unicode-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..970c81151daa
--- /dev/null
+++ b/dev-python/doctest-ignore-unicode/doctest-ignore-unicode-0.1.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Add flag to ignore unicode literal prefixes in doctests"
+HOMEPAGE="https://pypi.org/project/doctest-ignore-unicode/ https://github.com/gnublade/doctest-ignore-unicode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests nose
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index d7cea6a512f6..a9c86ef55124 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1068,7 +1068,7 @@ distutils-r1_python_test() {
case ${_DISTUTILS_TEST_RUNNER} in
nose)
- nosetests -v "${@}"
+ "${EPYTHON}" -m nose -v "${@}"
;;
pytest)
epytest