summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-16 18:55:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-16 18:57:07 +0100
commit8fd74c2124f4982f5a649b3404cb0730e4ff2264 (patch)
tree3402d756125a7f548174f21fbab8ed6dfc3e2c8a /xfce-extra
parentsci-geosciences/geocode-glib: Provide .svg files in SLOT="2" (diff)
downloadgentoo-8fd74c2124f4982f5a649b3404cb0730e4ff2264.tar.gz
gentoo-8fd74c2124f4982f5a649b3404cb0730e4ff2264.tar.bz2
gentoo-8fd74c2124f4982f5a649b3404cb0730e4ff2264.zip
xfce-extra/xfce4-places-plugin: Bump to 1.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index 25ac35fe179a..3cf33fd8a248 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-places-plugin-1.8.1.tar.bz2 380906 BLAKE2B 3b5c82fe3fb9fbcc0b9aa79df62da06025f5dd154d4323787d52cbf659351dcc808a4c6e8d4148332eb31a8d292b51d58dba6c81fdf49443b94928a1e82f66f0 SHA512 c0db29050df6ff2862a6ebc6f89d92e39f0c0511f9e719a979b5132935655078a5f5418b8b87bee2fbccaa37f5489d503dc1ae329eb7fd88970dc55b31db3324
DIST xfce4-places-plugin-1.8.2.tar.bz2 388168 BLAKE2B 4ffd6fddae71c40c82dd86427c742865a237d48650480db9b817e04f35d6b142896f51f63772f9ab3ca15f1fdccee492d442ee78a1033394154e561075ee66ac SHA512 ad298407183ea499bd4a7c923e80141886c7ca809f4af4184074a1c98e73c72fbf610e06bccdffe3c1bacce39d945dc094d0ea9a82ca67ff7f8b79c8d9c5c53d
+DIST xfce4-places-plugin-1.8.3.tar.bz2 388661 BLAKE2B c824db5b7cfb1458c3562ab8dc1334d8fd7223ede49c62f52def23c16899848490907a044998e205a31837c96264415c9cfe2ef7adac5ddabd9f4440cafae562 SHA512 31ab8a47606c6406e93a753c55eb902fb25828f2c89c31814c11534dde327e656678ffcd590b41ebfab0a761bfcf0dae72e1ca3bb84eef5d0592f52114556ac9
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.3.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.3.ebuild
new file mode 100644
index 000000000000..6dbca3313e8d
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-places-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}