summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild')
-rw-r--r--xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild b/xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild
new file mode 100644
index 000000000000..f93b668feec7
--- /dev/null
+++ b/xfce-extra/xfce-theme-manager/xfce-theme-manager-0.3.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+MY_PN=Xfce-Theme-Manager
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An alternative theme manager for The Xfce Desktop Environment"
+HOMEPAGE="http://keithhedger.hostingsiteforfree.com/pages/apps.html#themeed"
+SRC_URI="http://keithhedger.hostingsiteforfree.com/zips/xfcethememanager/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.30
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libXcursor
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ >=xfce-base/xfdesktop-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ DOCS=( ChangeLog )
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^Cat/s:;;Settings::' \
+ -e '/^Cat/s:Gnome:GNOME:' \
+ ${MY_PN}/resources/pixmaps/${MY_PN}.desktop || die
+
+ local configext desktopversion=10
+ has_version '>=xfce-base/xfdesktop-4.11' && desktopversion=11
+ [[ -x configure ]] || configext=.ac
+
+ sed -i \
+ -e '/^CFLAGS/s:=-Wall:"& $CFLAGS":' \
+ -e '/^CXXFLAGS/s:=-Wall:"& $CXXFLAGS":' \
+ -e "/^desktopversion/s:=.*:=$desktopversion:" \
+ configure${configext} || die
+
+ xfconf_src_prepare
+}
+
+src_install() {
+ xfconf_src_install
+ rm -f "${ED}"/usr/share/${MY_PN}/docs/gpl-3.0.txt
+}