summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-14 16:00:30 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-14 16:57:53 +0100
commit685299de13352c3139af1596c28f3e512c9e6612 (patch)
tree5ce0f063181439a18aa76500732bc5bac30952c4 /xfce-extra/thunar-volman
parentxfce-base/xfce4-panel: Bump to 4.12.2 (diff)
downloadgentoo-685299de13352c3139af1596c28f3e512c9e6612.tar.gz
gentoo-685299de13352c3139af1596c28f3e512c9e6612.tar.bz2
gentoo-685299de13352c3139af1596c28f3e512c9e6612.zip
xfce-extra/thunar-volman: Bump to 0.9.0 (GTK+3 port)
Diffstat (limited to 'xfce-extra/thunar-volman')
-rw-r--r--xfce-extra/thunar-volman/Manifest1
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-0.9.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/Manifest b/xfce-extra/thunar-volman/Manifest
index 961a7dc87ed7..52b4c378b905 100644
--- a/xfce-extra/thunar-volman/Manifest
+++ b/xfce-extra/thunar-volman/Manifest
@@ -1 +1,2 @@
DIST thunar-volman-0.8.1.tar.bz2 474769 BLAKE2B 2bf6378b35f0cd868cc7363909cc5d54a997a5a69758a27d45640968e3ef8d7cb3f5af185d1a8f83e8593610490a8566742070808ab85810cd3411856aa0030a SHA512 a82c019b028277d97e7903dcbeaf4704cb7fc1e95b0ea18c6290a7a8581355691990cbdb5fa0c234ed5dd51c1ba7f1bca9a495e60f9f8597a993845481113bb6
+DIST thunar-volman-0.9.0.tar.bz2 474533 BLAKE2B fff6292c7e613da47c32d92db9ffe0abd32ab2ba5c956c630208d2b3235d4f7a5e3aab5ddef291c0d185264afe6493566f4e5e0d73c60e093dd52567c5d5ff1e SHA512 d753e2aeded921e5652e6ace164845997dc3cdfbfd92561e2af822bffdf910a06850658a9f662198e4f7c485a3dc1226f97b573d28fb66e5ba490aa08f56a8f5
diff --git a/xfce-extra/thunar-volman/thunar-volman-0.9.0.ebuild b/xfce-extra/thunar-volman/thunar-volman-0.9.0.ebuild
new file mode 100644
index 000000000000..d9a80b036e34
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-0.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30:=
+ virtual/libgudev:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}