summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-27 10:39:18 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-19 10:22:46 +0200
commitbaf99691e2f0086e5967c92d11b3a3d61e4d5651 (patch)
tree9ef860314a493fe360712a98dc51c7928d74709c /x11-themes
parentgui-libs/gtksourceview: Bump to 5.12.1 (diff)
downloadgentoo-baf99691e2f0086e5967c92d11b3a3d61e4d5651.tar.gz
gentoo-baf99691e2f0086e5967c92d11b3a3d61e4d5651.tar.bz2
gentoo-baf99691e2f0086e5967c92d11b3a3d61e4d5651.zip
x11-themes/adwaita-icon-theme: Bump to 46.2
Closes: https://bugs.gentoo.org/927897 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index 32accfd46bfa..92fe13dca827 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST adwaita-icon-theme-3.32.0.tar.xz 18540012 BLAKE2B a82ca6758cdbf459ac617d3b3d834e4147c3a3c5e6ca7c705ed2d16e8cf0a1255f5ae999d7e930b9716585b8c498c220f1ab40fec929dde7679efd56f3b18a45 SHA512 9609732cd51c6794d4d86598818bb2a589b0f4b6b795e57f3507dad69b21ef1b2fc2e83e24e937428bbace32fcccf587a5771cbc02c5768206e704f0456a6d1d
DIST adwaita-icon-theme-45.0.tar.xz 4296512 BLAKE2B b069b12a85cd4e0aa17e1e457ef2083c259723c41e018db360076111e0c68a08189110c0bcd0808f0b31068c1b7c37436fd695ce8daf73b89fe8e63c7ed381b1 SHA512 0511acabb18cd8a07a53c5714d921b562a5d2ed5922d9922521b58d234518af7b9fd97d91e04d18d1a6c97d3a22fb555b8836288eba5ab7c5e9aa51807c2dbf4
+DIST adwaita-icon-theme-46.2.tar.xz 4597704 BLAKE2B 4ced0826a57915b02796e83b1066844e1e053d301eb802b455e3e994486441a166c4285e73062e569873b9725dc1daf330b47026966647c6aef5293f92aa0d96 SHA512 dc4126038b3f7415bc14dc258a7a7a449ae3c12ce635d26e40bea335a410e21ac434a00fc09c897b66d8a1acff58b900611d491cd338c70ddfa2cc8ec2f76a6e
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild
new file mode 100644
index 000000000000..5e55fddf6253
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="branding"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via
+# its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+# adwaita-icon-theme-legacy needed to be FDO compatible (as done in other distributions
+# as Fedora, https://bugs.gentoo.org/927897)
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+ x11-themes/adwaita-icon-theme-legacy
+"
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ cp "${WORKDIR}"/tango-gentoo-v1.1/scalable/gentoo.svg \
+ "${S}"/Adwaita/scalable/places/start-here.svg || die
+ fi
+
+ default
+}
+
+src_test() {
+ :; # No tests
+}
+
+src_install() {
+ meson_src_install
+
+ # Gentoo uses the following location for cursors too, but keep
+ # upstream path to prevent issues like bugs #838451, #834277, #834001
+ dosym ../../../../usr/share/icons/Adwaita/cursors /usr/share/cursors/xorg-x11/Adwaita
+}
+
+pkg_preinst() {
+ # Needed until bug #834600 is solved
+ if [[ -d "${EROOT}"/usr/share/cursors/xorg-x11/Adwaita ]] ; then
+ rm -r "${EROOT}"/usr/share/cursors/xorg-x11/Adwaita || die
+ fi
+ xdg_pkg_preinst
+}