summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-08 01:28:11 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-09 18:47:19 -0800
commit76f732449e41864d54bea20fc6ebd0a4d8f9bb9f (patch)
treec07acf55b6aa59c2eff970303fcb58c8e5cf55de /x11-themes
parentapp-editors/hexedit: add myself as maintainer (diff)
downloadgentoo-76f732449e41864d54bea20fc6ebd0a4d8f9bb9f.tar.gz
gentoo-76f732449e41864d54bea20fc6ebd0a4d8f9bb9f.tar.bz2
gentoo-76f732449e41864d54bea20fc6ebd0a4d8f9bb9f.zip
x11-themes/arc-theme: add 20220105
fixes app crashes with new gtk-4.6.0 no longer requires pre-rendering of PNGs add transparency use flag Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20220105.ebuild81
-rw-r--r--x11-themes/arc-theme/metadata.xml3
3 files changed, 84 insertions, 1 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index ca8cccb0d922..44994f18f5af 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -2,3 +2,4 @@ DIST arc-theme-20210412-pngs.tar.xz 159340 BLAKE2B 40027335b8b44ae38bfadfa52e088
DIST arc-theme-20210412.tar.xz 257248 BLAKE2B c525c3632670d8aa6b640baa8b3dddca6c5dd5f087734604c68d9140f810fc595f73db06f93b6193ba1c59a8cd85b87f5f6fda9777940adf36f3c436a8426810 SHA512 d3064546301e013a1e5a8db735346d74c73f37cbf808b7afeee6f88c820cea58ba6458fa63e1213377cdd33c8347167242e6f8f1eacf85ce212f3b2508c0bb80
DIST arc-theme-20211018-pngs.tar.xz 160836 BLAKE2B 4c2882ce03724c7abd8d4db31da82355d28b792a16648e010eca033f77d3ad6da8f7026e2562249caa993f2e8549191b6ec8d4473fbcab084ae3d91c468956c5 SHA512 6ac7bf27ebc258d0e2c2102ed286ba196d6f9c8343e1885d77d8f29cda0f8c247926003bd8c40165e08b9b3987f8a2f82800d509b78dd598d2e7ff8bea964831
DIST arc-theme-20211018.tar.xz 271084 BLAKE2B dc8808a5c7a0444d5ac11fa213b99b9633691ad920a07820752974f98febd8bc112a34568c38d354558e7876182278603ab66ebf8e50aa51f5eba431bd6b3433 SHA512 da46efc0e38efb7f1d0cd9a5d2c4e8f00f3b8d408ec50c54d89ef67fc3bb5ea253b5fb890b0cb8e82cafebd44a599d0de2369272ed88da73dd979052b130bd55
+DIST arc-theme-20220105.tar.xz 342432 BLAKE2B 37a4e196fbbe532e4f9036681770fb90843c8a4645b8218c471f2f5f68e7c0c07107a71698634a61553ba4f22f483a336b113ff6906fed48c0285a67321d0896 SHA512 dc2a1e1dad03fd187e8e571b752e52d73c7cbed24f3228f1782c4a4897b1085e2466f6f8373af32d650ad9835df3ad19a1206f3fa55d543115092aa46118e31f
diff --git a/x11-themes/arc-theme/arc-theme-20220105.ebuild b/x11-themes/arc-theme/arc-theme-20220105.ebuild
new file mode 100644
index 000000000000..b68e9713aa58
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20220105.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="A flat theme with transparent elements for GTK 2/3/4 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 +gtk4 mate +transparency xfce"
+
+GLIB_DEPEND="dev-libs/glib"
+SASSC_DEPEND="dev-lang/sassc"
+
+# Supports various GTK, GNOME Shell, and Cinnamon versions and uses
+# --version option for gnome-shell and cinnamon to determine which set of files to build.
+# Updates will therefore break existing installs but there's no way around this.
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.28
+ )
+ gtk3? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+ gtk4? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_configure() {
+ # Cinnamon still uses metacity themes for its window manager.
+ # so we enable metacity theme too if USE=cinnamon
+ # but only enable metacity if USE=mate
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon "cinnamon metacity") \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usev gtk4) \
+ $(! use cinnamon && usev mate metacity) \
+ $(usev xfce xfwm)
+ )
+
+ local emesonargs=(
+ # 4.0 dropped in Gentoo, 4.2 works with 4.6
+ # if we change that to allow auto-detection, a pkg-config dep will be required.
+ -Dgtk4_version=4.2
+ -Dthemes="${themes%,}"
+ $(meson_use gnome-shell gnome_shell_gresource)
+ $(meson_use transparency)
+ )
+
+ meson_src_configure
+}
diff --git a/x11-themes/arc-theme/metadata.xml b/x11-themes/arc-theme/metadata.xml
index c54d3e049299..29a9298fffd4 100644
--- a/x11-themes/arc-theme/metadata.xml
+++ b/x11-themes/arc-theme/metadata.xml
@@ -15,7 +15,8 @@
<flag name="gtk4">Install GTK+4 theme</flag>
<flag name="mate">Install Metacity theme for <pkg>mate-base/mate</pkg></flag>
<flag name="gnome-shell">Install theme for <pkg>gnome-base/gnome-shell</pkg></flag>
- <flag name="pre-rendered">Avoid <pkg>media-gfx/inkscape</pkg> and <pkg>media-gfx/optipng</pkg> dependencies by using pre-rendered PNGs</flag>
+ <flag name="pre-rendered" restrict="&lt;x11-themes/arc-theme-20220105">Avoid <pkg>media-gfx/inkscape</pkg> and <pkg>media-gfx/optipng</pkg> dependencies by using pre-rendered PNGs</flag>
+ <flag name="transparency" restrict="&gt;=x11-themes/arc-theme-20220105">Enable transparency</flag>
<flag name="xfce">Install theme for <pkg>xfce-base/xfwm4</pkg></flag>
</use>
</pkgmetadata>