summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 01:27:25 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 01:33:12 -0400
commite6b4ce564af1a145ba081df6abf355c284ea89e0 (patch)
tree223cb31593b681ae86b826258b1365e37ecd2206 /x11-terms
parentx11-terms/kitty-terminfo: add 0.36.4 (diff)
downloadgentoo-e6b4ce564af1a145ba081df6abf355c284ea89e0.tar.gz
gentoo-e6b4ce564af1a145ba081df6abf355c284ea89e0.tar.bz2
gentoo-e6b4ce564af1a145ba081df6abf355c284ea89e0.zip
x11-terms/kitty-shell-integration: add 0.36.4
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 8d5408aafa41..d2b85905dba6 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,3 +1,4 @@
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
DIST kitty-0.36.2.tar.xz 8899200 BLAKE2B ab7896c9b5f4a3b428a880663f000618cafff5e1837df693d56b0c7c5364aa7acfb8dd472886935594ecff05be30821c68e2fdc598a530ee36c55031956c2998 SHA512 14efd609f87aa50adc26585e80d3fa80328cbda7b0352eb1689ea585c24cc03fec06424e28d1278b4db6aa8f98ef1faf132ea602637d7781947b72bed53d4784
DIST kitty-0.36.3.tar.xz 8836304 BLAKE2B 0ed7c8ea92c8fedae64a1059b21f120fab3141607be27c74116f34ee637fc33899dc240954d47757f36ec487bba40f7856423777d756014a3dd5221329403293 SHA512 290ce8d1d64ed431221ecdc9f942218ee375d7c065193186ad3d2a58bb936ff206b6df3379cd0d4d233cbf3433f9fbeb16d0459704e343cb32305de841828513
+DIST kitty-0.36.4.tar.xz 8875060 BLAKE2B 530b11a719360997230ef12dc857dea975ccfce1f111c23ccabf392bd463ebe3ae80aef8cb8a1f7c3877e7847d750ad04f6185c0d8e05ac9770f2b7dfc407bf5 SHA512 3ffabb181903495d6a11a8b790e75331a5ab0986de0b7a7958ea7dfee724c29aee88c31672e2f7711d3fc51a81e1a3c84e4469228872aa62df840ded2c0d5218
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.4.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.4.ebuild
new file mode 100644
index 000000000000..a50a1338ca92
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash/,/etc/bash/bashrc.d/90-}kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}