summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-02-19 15:22:47 +0000
committerMatthew Smith <matthew@gentoo.org>2023-02-19 15:23:48 +0000
commitd68696fa4b551f716b5c4dd99a605a4531804982 (patch)
tree18d8789537e4721832b217535b94e83437d6a2b1 /x11-terms
parentapp-text/enchant: Version bump to 2.3.4 (diff)
downloadgentoo-d68696fa4b551f716b5c4dd99a605a4531804982.tar.gz
gentoo-d68696fa4b551f716b5c4dd99a605a4531804982.tar.bz2
gentoo-d68696fa4b551f716b5c4dd99a605a4531804982.zip
x11-terms/zutty: add 0.14
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.14.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index 6c5451a30555..7bc3b54fefbe 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1,2 +1,3 @@
DIST zutty-0.13-waf 105632 BLAKE2B 9edbaab125e398d3e0794f0ea0650cda833514f7e571ce5549d74c563c6adfd4483af34be4845d67993fe14bcacee89c02a8ca221673c472f6b16c6e27c0ad4d SHA512 ab756b7e3248bd6b87a58fd94d8d786c058889fa5015a2ed2eb2a05869af898324297a903810e43899de8eb226dc30a0a9605d7fdf6bec3bc05c68b74907e79f
DIST zutty-0.13.tar.gz 348348 BLAKE2B 35887597798ecee4912a76d74e943ab93682ee637eed0966d70e198d64c9960060eeb1a0b93a76596dd77aeea99b897bd2d54900f10a41a6a786776a5f202997 SHA512 b6514299520562f3ca9f29c80d252a571c0347603c918d15dde095b92be8e96e23a249b23d1d0efc0d7aca03138c07913d7f3dc0f3e91c8bf04e78a3444ac43e
+DIST zutty-0.14.tar.gz 351015 BLAKE2B 36dc0f285b48261e01b199bd047634f6893b9969766867a163a2e87d3169e5eb2ee6760dca7976bb93bbcbba2fed4e9d79230135605a8bd905e067686a3717e5 SHA512 d73894feefa1fb58c76aa5f9d68a47b9871ab8d02eb5dd2575769c4f082a65cb9df2bdb2478e5aa54d121eb19a16269f169e79d72f0df779760520f2d501c086
diff --git a/x11-terms/zutty/zutty-0.14.ebuild b/x11-terms/zutty/zutty-0.14.ebuild
new file mode 100644
index 000000000000..b6eb1002c7c0
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomscii/zutty"
+SRC_URI="https://github.com/tomscii/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.12-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )