summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-01-14 11:30:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-14 16:22:49 +0200
commit0b63f6c8919fa941324959b93578b603bd083597 (patch)
tree446bfc97e9044fd479b17d0f2b505ceecd47de52 /x11-terms
parentmedia-gfx/gmic: remove old (diff)
downloadgentoo-0b63f6c8919fa941324959b93578b603bd083597.tar.gz
gentoo-0b63f6c8919fa941324959b93578b603bd083597.tar.bz2
gentoo-0b63f6c8919fa941324959b93578b603bd083597.zip
x11-terms/kitty: fix live ebuild and add support for python 3.8
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14333 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/files/kitty-9999-flags.patch49
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild10
2 files changed, 5 insertions, 54 deletions
diff --git a/x11-terms/kitty/files/kitty-9999-flags.patch b/x11-terms/kitty/files/kitty-9999-flags.patch
deleted file mode 100644
index 0b60ae190fcb..000000000000
--- a/x11-terms/kitty/files/kitty-9999-flags.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Respect user CFLAGS.
-
---- kitty-0.15.0/setup.py
-+++ kitty-0.15.0/setup.py
-@@ -204,7 +204,7 @@
- if ccver >= (5, 0):
- df += ' -Og'
- float_conversion = '-Wfloat-conversion'
-- optimize = df if debug or sanitize else '-O3'
-+ optimize = ''
- sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
- cppflags = os.environ.get(
- 'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
-@@ -217,7 +217,7 @@
- cflags = os.environ.get(
- 'OVERRIDE_CFLAGS', (
- '-Wextra {} -Wno-missing-field-initializers -Wall -Wstrict-prototypes -D_POSIX_C_SOURCE=200809L -std=c11'
-- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
-+ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
- ).format(
- float_conversion, std,
- optimize,
-@@ -232,7 +232,7 @@
- )
- ldflags = os.environ.get(
- 'OVERRIDE_LDFLAGS',
-- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
-+ '-Wall ' + ' '.join(sanitize_args)
- )
- ldflags = shlex.split(ldflags)
- ldflags.append('-shared')
-@@ -611,7 +611,7 @@
-
-
- def build_launcher(args, launcher_dir='.', bundle_type='source'):
-- cflags = '-Wall -Werror -fpie'.split()
-+ cflags = '-Wall -fpie'.split()
- cppflags = []
- libs = []
- if args.profile or args.sanitize:
-@@ -623,8 +623,6 @@
- cflags.append('-g')
- if args.profile:
- libs.append('-lprofiler')
-- else:
-- cflags.append('-O3')
- if bundle_type.endswith('-freeze'):
- cppflags.append('-DFOR_BUNDLE')
- cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 6cf7eb8c9ee3..c62b5d655696 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-single-r1 toolchain-funcs xdg
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/kovidgoyal/kitty"
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug imagemagick wayland"
+IUSE="debug wayland"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
@@ -38,7 +38,7 @@ RDEPEND="
x11-libs/libXrandr
sys-apps/dbus
sys-libs/zlib
- imagemagick? ( virtual/imagemagick-tools )
+ virtual/imagemagick-tools
wayland? (
dev-libs/wayland
>=dev-libs/wayland-protocols-1.17
@@ -55,7 +55,7 @@ BDEPEND="virtual/pkgconfig"
[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
PATCHES=(
- "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/kitty-0.15.1-flags.patch
"${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
)