summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-26 13:18:00 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-26 16:00:34 +0100
commitd02562585be72b8944cc230bda6b84fcf9a6ee84 (patch)
treefe612d70833a6273ae665fc467b1a9516e9635d9 /x11-terms/gnome-terminal
parentgui-libs/vte-common: add 0.78.3 (diff)
downloadgentoo-d02562585be72b8944cc230bda6b84fcf9a6ee84.tar.gz
gentoo-d02562585be72b8944cc230bda6b84fcf9a6ee84.tar.bz2
gentoo-d02562585be72b8944cc230bda6b84fcf9a6ee84.zip
x11-terms/gnome-terminal: add 3.54.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.54.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index f48b2207c8e1..0302173b68c2 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -4,3 +4,4 @@ DIST gnome-terminal-3.48.1-cntr-ntfy-autottl-ts.patch.xz 37796 BLAKE2B 91a4d50a0
DIST gnome-terminal-3.50.1.tar.bz2 1702613 BLAKE2B e592114126dd5639169cd1cdfdc06ba10a2fd386b28d47372cdd0e2aed1a39252c660e0edb6cb946a88810a94640b6e40d7e2878c34740638b75049f6395471e SHA512 adff88f3afc3b68c1f17cf493c2ee032a9ccc35af89903c045c61fdddbf8b71c7d1c40a66e87def9dbdbdeb7e3bf5c1e8d5988e810476c5b2ad38ef9f0064eb5
DIST gnome-terminal-3.52.2-cntr-ntfy-autottl-ts.patch.xz 38768 BLAKE2B 1d3a7dad67a770c13ee63e321a91e93dba573d45f7983bae649419173cd7d4c650947596d15d38afb1d00f9415b40cb9816526ed9d56fe68317211fc94413c1d SHA512 dd9feeded7a6ea7051532b018c615f73da7d3ce18f00f52c8040cd87795881c07522506697a3bde7824f599dd3ec369162e28902d871ca99c61c4c4e42620ae9
DIST gnome-terminal-3.52.2.tar.bz2 1704471 BLAKE2B 898f397271fc6369c27e24e065bddab8546b934f8a3ba4a4c150e2191c76c10d558f33b35d83ab4c71a3363bc92f91e7d43e23bea6bc1e03ad54a5690c52cb0d SHA512 858896ebe20c58165338811d2d8050c35f4575cb0b06bfea25bf77e9bca1695472d712e6b7cf95b01ac9dca394725021a2a6c1f84f09e4c203ee21a381a8f706
+DIST gnome-terminal-3.54.3.tar.xz 2060008 BLAKE2B c9ba0f7e331e539e6c7941e4df410fae023f4ea6cd64c8c18463069c01af434b5be5fb949da107ca267d4ad7f948470e675ca9b35c2ca383c822487381a6b091 SHA512 89c58d9472081fc0a98224b65131628fb25753dca89ef27dd36ee4453d365175bbd77b69780a7143818edba285602329393cfe6491fef6589e19d8b1d50bed4e
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.54.3.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.54.3.ebuild
new file mode 100644
index 000000000000..6e537781b358
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.54.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+inherit flag-o-matic gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-terminal"
+
+LICENSE="GPL-3+ GPL-3 CC-BY-SA-3.0 FDL-1.3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="debug gnome-shell nautilus"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=gui-libs/libhandy-1.6.0:1
+ >=x11-libs/vte-0.78.0:2.91
+ >=dev-libs/libpcre2-10
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-3.44.1-fix-missing-wexitcode.patch
+ default
+}
+
+src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}