summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2024-02-25 11:31:44 +0100
committerAndreas Schuerch <nativemad@gentoo.org>2024-02-25 11:44:54 +0100
commit5c92a440b945b2fc4f34dc76d57e512dba63387a (patch)
treec7d0a29a51538c16605365934168e19d44be7a5c /x11-plugins
parentdev-libs/npth: Install npth-config program for older gnupg compatibility (diff)
downloadgentoo-5c92a440b945b2fc4f34dc76d57e512dba63387a.tar.gz
gentoo-5c92a440b945b2fc4f34dc76d57e512dba63387a.tar.bz2
gentoo-5c92a440b945b2fc4f34dc76d57e512dba63387a.zip
x11-plugins/pidgin-privacy-please: EAPI8 bump, fix LICENSE, fix bug #853022
Closes: https://bugs.gentoo.org/853022 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..8c2af2004dc2
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Pidgin plugin to stop spammers from annoying you"
+HOMEPAGE="https://code.google.com/p/pidgin-privacy-please/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="<net-im/pidgin-3[gtk]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ sed -e 's: -Wall -g3::' -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+}